package/python-pyqt5: select BR2_PACKAGE_QT5BASE_GUI
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 30 Dec 2019 21:48:42 +0000 (22:48 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 23 Jan 2020 22:36:29 +0000 (23:36 +0100)
Even though pyqt5 would be perfectly usable with just the core Qt5
modules (QtCore, QtDbus, ...), its configure.py script passes the -gui
option to qmake unconditionally. Therefore, make sure that GUI is built.

Fixes:
 - http://autobuild.buildroot.org/results/ea0c8db44aacf1ce76f75e8288969fe5da6690d9

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/python-pyqt5/Config.in
package/python-pyqt5/python-pyqt5.mk

index 20ac98870307737b36cdfd7d0240037464daa4f1..9fa7676f987133d5606ff9724f462776405c5d04 100644 (file)
@@ -5,6 +5,7 @@ config BR2_PACKAGE_PYTHON_PYQT5
        bool "python-pyqt5"
        depends on BR2_PACKAGE_QT5
        select BR2_PACKAGE_PYTHON_SIP
+       select BR2_PACKAGE_QT5BASE_GUI
        help
          Python bindings for Qt 5
 
index b6d559cd5b45b32fc1f27a2c70862445783f69af..260a93af9c3edf61d9d9731d8eef415d8617f12f 100644 (file)
@@ -12,9 +12,8 @@ PYTHON_PYQT5_LICENSE_FILES = LICENSE
 
 PYTHON_PYQT5_DEPENDENCIES = python-sip host-python-sip qt5base
 PYTHON_PYQT5_MODULES = \
-       QtCore \
+       QtCore QtGui \
        $(if $(BR2_PACKAGE_QT5BASE_DBUS),QtDBus) \
-       $(if $(BR2_PACKAGE_QT5BASE_GUI),QtGui) \
        $(if $(BR2_PACKAGE_QT5BASE_NETWORK),QtNetwork) \
        $(if $(BR2_PACKAGE_QT5BASE_OPENGL_LIB),QtOpenGL) \
        $(if $(BR2_PACKAGE_QT5BASE_PRINTSUPPORT),QtPrintSupport) \