lua: rename patches to the new convention
authorFrancois Perrad <fperrad@gmail.com>
Wed, 24 Dec 2014 09:10:34 +0000 (10:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 24 Dec 2014 11:00:51 +0000 (12:00 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
16 files changed:
package/lua/5.1.5/0001-root-path.patch [new file with mode: 0644]
package/lua/5.1.5/0002-shared-libs-for-lua.patch [new file with mode: 0644]
package/lua/5.1.5/0011-linenoise.patch [new file with mode: 0644]
package/lua/5.1.5/0012-fix-reader-at-eoz.patch [new file with mode: 0644]
package/lua/5.1.5/lua-01-root-path.patch [deleted file]
package/lua/5.1.5/lua-02-shared-libs-for-lua.patch [deleted file]
package/lua/5.1.5/lua-11-linenoise.patch [deleted file]
package/lua/5.1.5/lua-12-fix-reader-at-eoz.patch [deleted file]
package/lua/5.2.3/0001-root-path.patch [new file with mode: 0644]
package/lua/5.2.3/0002-shared-libs-for-lua.patch [new file with mode: 0644]
package/lua/5.2.3/0004-lua-pc.patch [new file with mode: 0644]
package/lua/5.2.3/0011-linenoise.patch [new file with mode: 0644]
package/lua/5.2.3/lua-01-root-path.patch [deleted file]
package/lua/5.2.3/lua-02-shared-libs-for-lua.patch [deleted file]
package/lua/5.2.3/lua-04-lua-pc.patch [deleted file]
package/lua/5.2.3/lua-11-linenoise.patch [deleted file]

diff --git a/package/lua/5.1.5/0001-root-path.patch b/package/lua/5.1.5/0001-root-path.patch
new file mode 100644 (file)
index 0000000..fd0da6e
--- /dev/null
@@ -0,0 +1,30 @@
+Adjust installation location to /usr.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/etc/lua.pc
+===================================================================
+--- a/etc/lua.pc
++++ b/etc/lua.pc
+@@ -8,7 +8,7 @@
+ R= 5.1.5
+ # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+-prefix= /usr/local
++prefix= /usr
+ INSTALL_BIN= ${prefix}/bin
+ INSTALL_INC= ${prefix}/include
+ INSTALL_LIB= ${prefix}/lib
+Index: b/src/luaconf.h
+===================================================================
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -94,7 +94,7 @@
+       ".\\?.dll;"  LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
+ #else
+-#define LUA_ROOT      "/usr/local/"
++#define LUA_ROOT      "/usr/"
+ #define LUA_LDIR      LUA_ROOT "share/lua/5.1/"
+ #define LUA_CDIR      LUA_ROOT "lib/lua/5.1/"
+ #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.1.5/0002-shared-libs-for-lua.patch b/package/lua/5.1.5/0002-shared-libs-for-lua.patch
new file mode 100644 (file)
index 0000000..3f863a5
--- /dev/null
@@ -0,0 +1,78 @@
+Add the compilation of a shared library.
+Compile the lua binary with the shared library.
+And install the shared library.
+The variable BUILDMODE allows to switch between static and dynamic mode.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -44,6 +44,7 @@
+ TO_BIN= lua luac
+ TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
+ TO_LIB= liblua.a
++TO_SOLIB = liblua.so.$(R)
+ TO_MAN= lua.1 luac.1
+ # Lua version and release.
+@@ -61,6 +62,8 @@
+ install: dummy
+       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
+       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
++      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
++      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
+       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
+       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -23,6 +23,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+ LUA_A=        liblua.a
++LUA_SO=       liblua.so
+ CORE_O=       lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
+       lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o  \
+       lundump.o lvm.o lzio.o
+@@ -36,8 +37,13 @@
+ LUAC_O=       luac.o print.o
+ ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
++ifneq (dynamic,$(BUILDMODE))
+ ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++else
++ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
++endif
+ ALL_A= $(LUA_A)
++ALL_SO= $(LUA_SO)
+ default: $(PLAT)
+@@ -47,12 +53,23 @@
+ a:    $(ALL_A)
++so:   $(ALL_SO)
++
+ $(LUA_A): $(CORE_O) $(LIB_O)
+       $(AR) $@ $(CORE_O) $(LIB_O)     # DLL needs all object files
+       $(RANLIB) $@
++$(LUA_SO): $(CORE_O) $(LIB_O)
++      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++      ln -fs $@.$(PKG_VERSION) $@
++
++ifneq (dynamic,$(BUILDMODE))
+ $(LUA_T): $(LUA_O) $(LUA_A)
+       $(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
++else
++$(LUA_T): $(LUA_O) $(LUA_SO)
++      $(CC) -o $@ -L. $(MYLDFLAGS) $(LUA_O) -llua $(LIBS)
++endif
+ $(LUAC_T): $(LUAC_O) $(LUA_A)
+       $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.1.5/0011-linenoise.patch b/package/lua/5.1.5/0011-linenoise.patch
new file mode 100644 (file)
index 0000000..488c080
--- /dev/null
@@ -0,0 +1,24 @@
+Add support of linenoise (replace readline)
+
+see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/luaconf.h
+===================================================================
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -279,6 +279,13 @@
+       if (lua_strlen(L,idx) > 0)  /* non-empty line? */ \
+         add_history(lua_tostring(L, idx));  /* add it to history */
+ #define lua_freeline(L,b)     ((void)L, free(b))
++#elif defined(LUA_USE_LINENOISE)
++#include <linenoise.h>
++#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
++#define lua_saveline(L,idx) \
++      if (lua_strlen(L,idx) > 0)  /* non-empty line? */ \
++        linenoiseHistoryAdd(lua_tostring(L, idx));  /* add it to history */
++#define lua_freeline(L,b)     ((void)L, free(b))
+ #else
+ #define lua_readline(L,b,p)   \
+       ((void)L, fputs(p, stdout), fflush(stdout),  /* show prompt */ \
diff --git a/package/lua/5.1.5/0012-fix-reader-at-eoz.patch b/package/lua/5.1.5/0012-fix-reader-at-eoz.patch
new file mode 100644 (file)
index 0000000..17a28ba
--- /dev/null
@@ -0,0 +1,46 @@
+When loading a file, Lua may call the reader function again after it returned end of input.
+
+Fetch from: http://www.lua.org/bugs.html#5.1.5-2
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/lzio.c
+===================================================================
+--- a/src/lzio.c
++++ b/src/lzio.c
+@@ -22,10 +22,14 @@
+   size_t size;
+   lua_State *L = z->L;
+   const char *buff;
++  if (z->eoz) return EOZ;
+   lua_unlock(L);
+   buff = z->reader(L, z->data, &size);
+   lua_lock(L);
+-  if (buff == NULL || size == 0) return EOZ;
++  if (buff == NULL || size == 0) {
++    z->eoz = 1;  /* avoid calling reader function next time */
++    return EOZ;
++  }
+   z->n = size - 1;
+   z->p = buff;
+   return char2int(*(z->p++));
+@@ -51,6 +55,7 @@
+   z->data = data;
+   z->n = 0;
+   z->p = NULL;
++  z->eoz = 0;
+ }
+Index: b/src/lzio.h
+===================================================================
+--- a/src/lzio.h
++++ b/src/lzio.h
+@@ -59,6 +59,7 @@
+   lua_Reader reader;
+   void* data;                 /* additional data */
+   lua_State *L;                       /* Lua state (for reader) */
++  int eoz;                    /* true if reader has no more data */
+ };
diff --git a/package/lua/5.1.5/lua-01-root-path.patch b/package/lua/5.1.5/lua-01-root-path.patch
deleted file mode 100644 (file)
index fd0da6e..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Adjust installation location to /usr.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/etc/lua.pc
-===================================================================
---- a/etc/lua.pc
-+++ b/etc/lua.pc
-@@ -8,7 +8,7 @@
- R= 5.1.5
- # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
--prefix= /usr/local
-+prefix= /usr
- INSTALL_BIN= ${prefix}/bin
- INSTALL_INC= ${prefix}/include
- INSTALL_LIB= ${prefix}/lib
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -94,7 +94,7 @@
-       ".\\?.dll;"  LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
- #else
--#define LUA_ROOT      "/usr/local/"
-+#define LUA_ROOT      "/usr/"
- #define LUA_LDIR      LUA_ROOT "share/lua/5.1/"
- #define LUA_CDIR      LUA_ROOT "lib/lua/5.1/"
- #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.1.5/lua-02-shared-libs-for-lua.patch b/package/lua/5.1.5/lua-02-shared-libs-for-lua.patch
deleted file mode 100644 (file)
index 3f863a5..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Add the compilation of a shared library.
-Compile the lua binary with the shared library.
-And install the shared library.
-The variable BUILDMODE allows to switch between static and dynamic mode.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -44,6 +44,7 @@
- TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h ../etc/lua.hpp
- TO_LIB= liblua.a
-+TO_SOLIB = liblua.so.$(R)
- TO_MAN= lua.1 luac.1
- # Lua version and release.
-@@ -61,6 +62,8 @@
- install: dummy
-       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
-       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
-+      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
-+      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
-       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
-       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -23,6 +23,7 @@
- PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
- LUA_A=        liblua.a
-+LUA_SO=       liblua.so
- CORE_O=       lapi.o lcode.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o lmem.o \
-       lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o ltm.o  \
-       lundump.o lvm.o lzio.o
-@@ -36,8 +37,13 @@
- LUAC_O=       luac.o print.o
- ALL_O= $(CORE_O) $(LIB_O) $(LUA_O) $(LUAC_O)
-+ifneq (dynamic,$(BUILDMODE))
- ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+else
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
-+endif
- ALL_A= $(LUA_A)
-+ALL_SO= $(LUA_SO)
- default: $(PLAT)
-@@ -47,12 +53,23 @@
- a:    $(ALL_A)
-+so:   $(ALL_SO)
-+
- $(LUA_A): $(CORE_O) $(LIB_O)
-       $(AR) $@ $(CORE_O) $(LIB_O)     # DLL needs all object files
-       $(RANLIB) $@
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-+      ln -fs $@.$(PKG_VERSION) $@
-+
-+ifneq (dynamic,$(BUILDMODE))
- $(LUA_T): $(LUA_O) $(LUA_A)
-       $(CC) -o $@ $(MYLDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-+else
-+$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. $(MYLDFLAGS) $(LUA_O) -llua $(LIBS)
-+endif
- $(LUAC_T): $(LUAC_O) $(LUA_A)
-       $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.1.5/lua-11-linenoise.patch b/package/lua/5.1.5/lua-11-linenoise.patch
deleted file mode 100644 (file)
index 488c080..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Add support of linenoise (replace readline)
-
-see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -279,6 +279,13 @@
-       if (lua_strlen(L,idx) > 0)  /* non-empty line? */ \
-         add_history(lua_tostring(L, idx));  /* add it to history */
- #define lua_freeline(L,b)     ((void)L, free(b))
-+#elif defined(LUA_USE_LINENOISE)
-+#include <linenoise.h>
-+#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
-+#define lua_saveline(L,idx) \
-+      if (lua_strlen(L,idx) > 0)  /* non-empty line? */ \
-+        linenoiseHistoryAdd(lua_tostring(L, idx));  /* add it to history */
-+#define lua_freeline(L,b)     ((void)L, free(b))
- #else
- #define lua_readline(L,b,p)   \
-       ((void)L, fputs(p, stdout), fflush(stdout),  /* show prompt */ \
diff --git a/package/lua/5.1.5/lua-12-fix-reader-at-eoz.patch b/package/lua/5.1.5/lua-12-fix-reader-at-eoz.patch
deleted file mode 100644 (file)
index 17a28ba..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-When loading a file, Lua may call the reader function again after it returned end of input.
-
-Fetch from: http://www.lua.org/bugs.html#5.1.5-2
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/lzio.c
-===================================================================
---- a/src/lzio.c
-+++ b/src/lzio.c
-@@ -22,10 +22,14 @@
-   size_t size;
-   lua_State *L = z->L;
-   const char *buff;
-+  if (z->eoz) return EOZ;
-   lua_unlock(L);
-   buff = z->reader(L, z->data, &size);
-   lua_lock(L);
--  if (buff == NULL || size == 0) return EOZ;
-+  if (buff == NULL || size == 0) {
-+    z->eoz = 1;  /* avoid calling reader function next time */
-+    return EOZ;
-+  }
-   z->n = size - 1;
-   z->p = buff;
-   return char2int(*(z->p++));
-@@ -51,6 +55,7 @@
-   z->data = data;
-   z->n = 0;
-   z->p = NULL;
-+  z->eoz = 0;
- }
-Index: b/src/lzio.h
-===================================================================
---- a/src/lzio.h
-+++ b/src/lzio.h
-@@ -59,6 +59,7 @@
-   lua_Reader reader;
-   void* data;                 /* additional data */
-   lua_State *L;                       /* Lua state (for reader) */
-+  int eoz;                    /* true if reader has no more data */
- };
diff --git a/package/lua/5.2.3/0001-root-path.patch b/package/lua/5.2.3/0001-root-path.patch
new file mode 100644 (file)
index 0000000..c6f242c
--- /dev/null
@@ -0,0 +1,17 @@
+Adjust installation location to /usr.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/luaconf.h
+===================================================================
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -100,7 +100,7 @@
+ #else                 /* }{ */
+ #define LUA_VDIR      LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
+-#define LUA_ROOT      "/usr/local/"
++#define LUA_ROOT      "/usr/"
+ #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR
+ #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR
+ #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.2.3/0002-shared-libs-for-lua.patch b/package/lua/5.2.3/0002-shared-libs-for-lua.patch
new file mode 100644 (file)
index 0000000..3cf3b24
--- /dev/null
@@ -0,0 +1,78 @@
+Add the compilation of a shared library.
+Compile the lua binary with the shared library.
+And install the shared library.
+The variable BUILDMODE allows to switch between static and dynamic mode.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,7 @@
+ TO_BIN= lua luac
+ TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
+ TO_LIB= liblua.a
++TO_SOLIB = liblua.so.$(R)
+ TO_MAN= lua.1 luac.1
+ # Lua version and release.
+@@ -60,6 +61,8 @@
+ install: dummy
+       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
+       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
++      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
++      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
+       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
+       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -29,6 +29,7 @@
+ PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
+ LUA_A=        liblua.a
++LUA_SO=       liblua.so
+ CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+       ltm.o lundump.o lvm.o lzio.o
+@@ -43,8 +44,13 @@
+ LUAC_O=       luac.o
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
++ifneq (dynamic,$(BUILDMODE))
+ ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++else
++ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
++endif
+ ALL_A= $(LUA_A)
++ALL_SO= $(LUA_SO)
+ # Targets start here.
+ default: $(PLAT)
+@@ -55,12 +61,23 @@
+ a:    $(ALL_A)
++so:   $(ALL_SO)
++
+ $(LUA_A): $(BASE_O)
+       $(AR) $@ $(BASE_O)
+       $(RANLIB) $@
++$(LUA_SO): $(CORE_O) $(LIB_O)
++      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++      ln -fs $@.$(PKG_VERSION) $@
++
++ifneq (dynamic,$(BUILDMODE))
+ $(LUA_T): $(LUA_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
++else
++$(LUA_T): $(LUA_O) $(LUA_SO)
++      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
++endif
+ $(LUAC_T): $(LUAC_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.2.3/0004-lua-pc.patch b/package/lua/5.2.3/0004-lua-pc.patch
new file mode 100644 (file)
index 0000000..62acb20
--- /dev/null
@@ -0,0 +1,40 @@
+add lua.pc
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/etc/lua.pc
+===================================================================
+--- /dev/null
++++ b/etc/lua.pc
+@@ -0,0 +1,31 @@
++# lua.pc -- pkg-config data for Lua
++
++# vars from install Makefile
++
++# grep '^V=' ../Makefile
++V= 5.2
++# grep '^R=' ../Makefile
++R= 5.2.3
++
++# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
++prefix= /usr
++INSTALL_BIN= ${prefix}/bin
++INSTALL_INC= ${prefix}/include
++INSTALL_LIB= ${prefix}/lib
++INSTALL_MAN= ${prefix}/man/man1
++INSTALL_LMOD= ${prefix}/share/lua/${V}
++INSTALL_CMOD= ${prefix}/lib/lua/${V}
++
++# canonical vars
++exec_prefix=${prefix}
++libdir=${exec_prefix}/lib
++includedir=${prefix}/include
++
++Name: Lua
++Description: An Extensible Extension Language
++Version: ${R}
++Requires: 
++Libs: -L${libdir} -llua -lm
++Cflags: -I${includedir}
++
++# (end of lua.pc)
diff --git a/package/lua/5.2.3/0011-linenoise.patch b/package/lua/5.2.3/0011-linenoise.patch
new file mode 100644 (file)
index 0000000..b1f228c
--- /dev/null
@@ -0,0 +1,26 @@
+Add support of linenoise (replace readline)
+
+see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/lua.c
+===================================================================
+--- a/src/lua.c
++++ b/src/lua.c
+@@ -72,6 +72,15 @@
+           add_history(lua_tostring(L, idx));  /* add it to history */
+ #define lua_freeline(L,b)     ((void)L, free(b))
++#elif defined(LUA_USE_LINENOISE)
++
++#include <linenoise.h>
++#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
++#define lua_saveline(L,idx) \
++      if (lua_rawlen(L,idx) > 0)  /* non-empty line? */ \
++        linenoiseHistoryAdd(lua_tostring(L, idx));  /* add it to history */
++#define lua_freeline(L,b)     ((void)L, free(b))
++
+ #elif !defined(lua_readline)
+ #define lua_readline(L,b,p) \
diff --git a/package/lua/5.2.3/lua-01-root-path.patch b/package/lua/5.2.3/lua-01-root-path.patch
deleted file mode 100644 (file)
index c6f242c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Adjust installation location to /usr.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -100,7 +100,7 @@
- #else                 /* }{ */
- #define LUA_VDIR      LUA_VERSION_MAJOR "." LUA_VERSION_MINOR "/"
--#define LUA_ROOT      "/usr/local/"
-+#define LUA_ROOT      "/usr/"
- #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR
- #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR
- #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.2.3/lua-02-shared-libs-for-lua.patch b/package/lua/5.2.3/lua-02-shared-libs-for-lua.patch
deleted file mode 100644 (file)
index 3cf3b24..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Add the compilation of a shared library.
-Compile the lua binary with the shared library.
-And install the shared library.
-The variable BUILDMODE allows to switch between static and dynamic mode.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -42,6 +42,7 @@
- TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
- TO_LIB= liblua.a
-+TO_SOLIB = liblua.so.$(R)
- TO_MAN= lua.1 luac.1
- # Lua version and release.
-@@ -60,6 +61,8 @@
- install: dummy
-       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
-       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
-+      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
-+      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
-       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
-       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -29,6 +29,7 @@
- PLATS= aix ansi bsd freebsd generic linux macosx mingw posix solaris
- LUA_A=        liblua.a
-+LUA_SO=       liblua.so
- CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
-       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
-       ltm.o lundump.o lvm.o lzio.o
-@@ -43,8 +44,13 @@
- LUAC_O=       luac.o
- ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-+ifneq (dynamic,$(BUILDMODE))
- ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+else
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
-+endif
- ALL_A= $(LUA_A)
-+ALL_SO= $(LUA_SO)
- # Targets start here.
- default: $(PLAT)
-@@ -55,12 +61,23 @@
- a:    $(ALL_A)
-+so:   $(ALL_SO)
-+
- $(LUA_A): $(BASE_O)
-       $(AR) $@ $(BASE_O)
-       $(RANLIB) $@
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-+      ln -fs $@.$(PKG_VERSION) $@
-+
-+ifneq (dynamic,$(BUILDMODE))
- $(LUA_T): $(LUA_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-+else
-+$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
-+endif
- $(LUAC_T): $(LUAC_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.2.3/lua-04-lua-pc.patch b/package/lua/5.2.3/lua-04-lua-pc.patch
deleted file mode 100644 (file)
index 62acb20..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-add lua.pc
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/etc/lua.pc
-===================================================================
---- /dev/null
-+++ b/etc/lua.pc
-@@ -0,0 +1,31 @@
-+# lua.pc -- pkg-config data for Lua
-+
-+# vars from install Makefile
-+
-+# grep '^V=' ../Makefile
-+V= 5.2
-+# grep '^R=' ../Makefile
-+R= 5.2.3
-+
-+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-+prefix= /usr
-+INSTALL_BIN= ${prefix}/bin
-+INSTALL_INC= ${prefix}/include
-+INSTALL_LIB= ${prefix}/lib
-+INSTALL_MAN= ${prefix}/man/man1
-+INSTALL_LMOD= ${prefix}/share/lua/${V}
-+INSTALL_CMOD= ${prefix}/lib/lua/${V}
-+
-+# canonical vars
-+exec_prefix=${prefix}
-+libdir=${exec_prefix}/lib
-+includedir=${prefix}/include
-+
-+Name: Lua
-+Description: An Extensible Extension Language
-+Version: ${R}
-+Requires: 
-+Libs: -L${libdir} -llua -lm
-+Cflags: -I${includedir}
-+
-+# (end of lua.pc)
diff --git a/package/lua/5.2.3/lua-11-linenoise.patch b/package/lua/5.2.3/lua-11-linenoise.patch
deleted file mode 100644 (file)
index b1f228c..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Add support of linenoise (replace readline)
-
-see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/lua.c
-===================================================================
---- a/src/lua.c
-+++ b/src/lua.c
-@@ -72,6 +72,15 @@
-           add_history(lua_tostring(L, idx));  /* add it to history */
- #define lua_freeline(L,b)     ((void)L, free(b))
-+#elif defined(LUA_USE_LINENOISE)
-+
-+#include <linenoise.h>
-+#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
-+#define lua_saveline(L,idx) \
-+      if (lua_rawlen(L,idx) > 0)  /* non-empty line? */ \
-+        linenoiseHistoryAdd(lua_tostring(L, idx));  /* add it to history */
-+#define lua_freeline(L,b)     ((void)L, free(b))
-+
- #elif !defined(lua_readline)
- #define lua_readline(L,b,p) \