yaffs2: new filesystem type
authorWill Wagner <will_wagner@carallon.com>
Mon, 15 Jul 2013 11:11:24 +0000 (12:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 16:07:11 +0000 (18:07 +0200)
[Thomas: remove BR2_TARGET_ROOTFS_YAFFS_PATH option, rename to yaffs2
instead of yaffs.]

Signed-off-by: Will Wagner <willw@carallon.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/Config.in
fs/yaffs2/Config.in [new file with mode: 0644]
fs/yaffs2/yaffs.mk [new file with mode: 0644]

index da4c5ff1b4203f39585a887419c4a58bb4985bfb..585311342788d5309880cdedd94a9e80b66248c3 100644 (file)
@@ -11,5 +11,6 @@ source "fs/romfs/Config.in"
 source "fs/squashfs/Config.in"
 source "fs/tar/Config.in"
 source "fs/ubifs/Config.in"
+source "fs/yaffs2/Config.in"
 
 endmenu
diff --git a/fs/yaffs2/Config.in b/fs/yaffs2/Config.in
new file mode 100644 (file)
index 0000000..27da4ba
--- /dev/null
@@ -0,0 +1,4 @@
+config BR2_TARGET_ROOTFS_YAFFS2
+       bool "yaffs2 root filesystem"
+       help
+         Build a yaffs2 root filesystem
diff --git a/fs/yaffs2/yaffs.mk b/fs/yaffs2/yaffs.mk
new file mode 100644 (file)
index 0000000..19bdbe8
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# Build the yaffs2 root filesystem image
+#
+################################################################################
+
+ROOTFS_YAFFS2_DEPENDENCIES = host-yaffs2utils
+
+define ROOTFS_YAFFS2_CMD
+       $(HOST_DIR)/usr/bin/mkyaffs2 --all-root $(TARGET_DIR) $@
+endef
+
+$(eval $(call ROOTFS_TARGET,yaffs2))