Makefile: use absolute path for TOPDIR
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Nov 2009 16:29:01 +0000 (17:29 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Nov 2009 16:31:56 +0000 (17:31 +0100)
Reported by mr_claus on IRC.

This ensure DL_DIR is always an absolute path, like it was before the
build dir reorganization - Fixes vim (patch) build.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
Makefile

diff --git a/CHANGES b/CHANGES
index 97ca4e745ed58952834baec7666ca82139900600..d319525327636183c8d9ec0ce0715ac062526858 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Additional fixes and cleanups.
 
-       Updated/fixed packages: alsamixergui, fltk, ncurses
+       Updated/fixed packages: alsamixergui, fltk, ncurses, vim
 
        Issues resolved (http://bugs.uclibc.org):
 
index 018cf6ded5e18441c2bf008e94b5371e64d68b65..904121e2e4c2ea335587850a917b44a5b958ae6a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -22,7 +22,8 @@
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR:=.
+# absolute path
+TOPDIR:=$(shell pwd)
 CONFIG_CONFIG_IN=Config.in
 CONFIG_DEFCONFIG=.defconfig
 CONFIG=package/config