dhcpcd: fix ipv6 related compile failure
authorPeter Seiderer <ps.report@gmx.net>
Tue, 28 Apr 2015 19:36:28 +0000 (21:36 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Apr 2015 19:44:55 +0000 (21:44 +0200)
Add '-D_GNU_SOURCE' to gain missing struct in6_pktinfo definition.

Fixes [1]:

ipv6.h:211:41: error: invalid application of 'sizeof' to incomplete type 'struct in6_pktinfo'
  unsigned char sndbuf[CMSG_SPACE(sizeof(struct in6_pktinfo))];
                                         ^
ipv6.h:195:38: error: invalid application of 'sizeof' to incomplete type 'struct in6_pktinfo'
 #define IP6BUFLEN (CMSG_SPACE(sizeof(struct in6_pktinfo)) + \
                                      ^
ipv6.h:214:23: note: in expansion of macro 'IP6BUFLEN'
  unsigned char rcvbuf[IP6BUFLEN];

[1] http://autobuild.buildroot.net/results/523/523858fb930e74fe28f24989ff0697693b5fdd67

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dhcpcd/dhcpcd.mk

index 405635197e572b461a61df0ac6ac7f6c26806960..756a660085cbdea90a0f0323bb49f8047724ffc4 100644 (file)
@@ -20,8 +20,8 @@ endif
 
 define DHCPCD_CONFIGURE_CMDS
        (cd $(@D); \
-       $(TARGET_CONFIGURE_OPTS) ./configure \
-               --os=linux \
+       $(TARGET_CONFIGURE_OPTS) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
+               ./configure --os=linux \
                $(DHCPCD_CONFIG_OPTS) )
 endef