Missed a bugfix patch. Also, allow multiple patches.
authorManuel Novoa III <mjn3@codepoet.org>
Sat, 6 Mar 2004 22:57:23 +0000 (22:57 -0000)
committerManuel Novoa III <mjn3@codepoet.org>
Sat, 6 Mar 2004 22:57:23 +0000 (22:57 -0000)
make/dnsmasq1.mk
sources/dnsmasq1-100-bugfix.patch [new file with mode: 0644]
sources/dnsmasq1.patch [deleted file]

index 1da42d4bf38d9ba23c3438e2b510b8deb00b5689..b6160b1a6838fe72c1ecbac2bdeac05be87c7657 100644 (file)
@@ -15,7 +15,7 @@ $(DL_DIR)/$(DNSMASQ1_SOURCE):
 
 $(DNSMASQ1_DIR)/.source: $(DL_DIR)/$(DNSMASQ1_SOURCE)
        zcat $(DL_DIR)/$(DNSMASQ1_SOURCE) | tar -C $(BUILD_DIR) -xvf -
-       patch -p1 -d $(DNSMASQ1_DIR) < $(SOURCE_DIR)/dnsmasq1.patch 
+       $(SOURCE_DIR)/patch-kernel.sh $(DNSMASQ1_DIR) $(SOURCE_DIR) dnsmasq1-*.patch
        touch $(DNSMASQ1_DIR)/.source
 
 $(DNSMASQ1_DIR)/$(DNSMASQ1_BINARY): $(DNSMASQ1_DIR)/.source
diff --git a/sources/dnsmasq1-100-bugfix.patch b/sources/dnsmasq1-100-bugfix.patch
new file mode 100644 (file)
index 0000000..c676a1a
--- /dev/null
@@ -0,0 +1,25 @@
+--- dnsmasq-1.18/config.h.dist 2004-03-01 22:25:12.000000000 -0600
++++ dnsmasq-1.18/config.h      2004-03-01 22:26:50.000000000 -0600
+@@ -126,7 +126,9 @@
+ /* Must preceed __linux__ since uClinux defines __linux__ too. */
+ #if defined(__uClinux__) || defined(__UCLIBC__)
++#ifndef __UCLIBC_HAS_IPV6__
+ #undef HAVE_LINUX_IPV6_PROC
++#endif
+ #define HAVE_GETOPT_LONG
+ #undef HAVE_ARC4RANDOM
+ #define HAVE_RANDOM
+diff -x CVS -urN dnsmasq-1.18/option.c dnsmasq.old/option.c
+--- dnsmasq-1.18/option.c      2003-11-05 08:22:18.000000000 -0600
++++ dnsmasq.old/option.c       2004-01-05 23:40:11.000000000 -0600
+@@ -578,8 +578,8 @@
+ #ifdef HAVE_IPV6
+           else if (tmp->source_addr.sa.sa_family == AF_INET6)
+             tmp->source_addr.in6.sin6_port = htons(*query_port);
+-        }
+ #endif  
++        }
+     }
+   
+   if (*if_addrs)
diff --git a/sources/dnsmasq1.patch b/sources/dnsmasq1.patch
deleted file mode 100644 (file)
index 0635ed3..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- dnsmasq-1.18/config.h.dist 2004-03-01 22:25:12.000000000 -0600
-+++ dnsmasq-1.18/config.h      2004-03-01 22:26:50.000000000 -0600
-@@ -126,7 +126,9 @@
- /* Must preceed __linux__ since uClinux defines __linux__ too. */
- #if defined(__uClinux__) || defined(__UCLIBC__)
-+#ifndef __UCLIBC_HAS_IPV6__
- #undef HAVE_LINUX_IPV6_PROC
-+#endif
- #define HAVE_GETOPT_LONG
- #undef HAVE_ARC4RANDOM
- #define HAVE_RANDOM