package/openvmtools: fix build with NLS
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 23 Feb 2020 17:29:02 +0000 (18:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 23 Feb 2020 20:46:22 +0000 (21:46 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/e0e7ed448df8bdd6cb13a0989d7a6c7dbaa5bc4e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openvmtools/openvmtools.mk

index 68afa1707852803be23058e500727b6696483d22..4201c6daa052b55576e03efdad95ac66920cce0d 100644 (file)
@@ -17,8 +17,14 @@ OPENVMTOOLS_CONF_OPTS = --with-dnet \
        --without-icu --without-x --without-gtk2 \
        --without-gtkmm --without-kernel-modules \
        --disable-deploypkg --without-xerces
-OPENVMTOOLS_CONF_ENV += CUSTOM_DNET_CPPFLAGS=" "
-OPENVMTOOLS_DEPENDENCIES = host-nfs-utils libglib2 libdnet
+OPENVMTOOLS_CONF_ENV += \
+       CUSTOM_DNET_CPPFLAGS=" " \
+       LIBS=$(TARGET_NLS_LIBS)
+OPENVMTOOLS_DEPENDENCIES = \
+       host-nfs-utils \
+       libglib2 \
+       libdnet \
+       $(TARGET_NLS_DEPENDENCIES)
 
 ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
 OPENVMTOOLS_DEPENDENCIES += libtirpc