projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9f8180d
)
pixman: unbreak on nios codesourcery 2014.05
author
Peter Korsgaard
<peter@korsgaard.com>
Fri, 31 Oct 2014 10:12:05 +0000
(11:12 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Fri, 31 Oct 2014 10:13:39 +0000
(11:13 +0100)
Fixes
http://autobuild.buildroot.net/results/ec3/
ec31257a66583ca69bbad5ecfedb4c25b85268ee
/
http://autobuild.buildroot.net/results/b24/
b241ef7b7283efd92028d98355f268d93a12ffdd
/
http://autobuild.buildroot.net/results/36c/
36cc9386747854b632ec4e22bed8f32a0e2eec32
/
http://autobuild.buildroot.net/results/b8a/
b8a2de871eec249d03744fcd4ea6b5d3d1b01bd5
/
And many others.
The toolchain gets confused about TLS access through the GOT (PIC), so
disable TLS support in pixman.
The error from the assembler is:
movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
{standard input}:172: Error: bad expression
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pixman/pixman.mk
patch
|
blob
|
history
diff --git
a/package/pixman/pixman.mk
b/package/pixman/pixman.mk
index 87a2c66d2e1621a4f8d25d9bb5daebdef608ff6d..a244ea82ba8c27322fe82d40783f21d0861159c1 100644
(file)
--- a/
package/pixman/pixman.mk
+++ b/
package/pixman/pixman.mk
@@
-22,5
+22,12
@@
ifneq ($(BR2_iwmmxt),y)
PIXMAN_CONF_OPTS += --disable-arm-iwmmxt
endif
+# toolchain gets confused about TLS access through GOT (PIC), so disable TLS
+# movhi r4, %got_hiadj(%tls_ldo(fast_path_cache))
+# {standard input}:172: Error: bad expression
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405),y)
+PIXMAN_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -DPIXMAN_NO_TLS"
+endif
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))