linux: add knob to force a rebuild of the kernel
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 Jul 2008 11:43:57 +0000 (11:43 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 9 Jul 2008 11:43:57 +0000 (11:43 -0000)
Makes development easier. Thanks to Brian Beattie for this handy idea.

1df013316b in Bernhards tree.

target/linux/Makefile.in

index bd9f203092313aacb891197cd5218c3f8931ab96..eb2b36ee117797a4ca874361b786b4bc64463a2f 100644 (file)
@@ -233,6 +233,10 @@ linux26-config: host-sed $(LINUX26_DIR)/.configured
 linux26-update:
        cp -dpf $(LINUX26_DIR)/.config $(LINUX26_KCONFIG)
 
+# force rebuild
+linux26-force:
+       touch $(LINUX26_DIR)/.configured
+
 # This has been renamed so we do _NOT_ by default run this on 'make clean'
 linux26clean:
        rm -f $(LINUX26_KERNEL) $(LINUX26_DIR)/.configured