package/ltrace: bump ltrace using a more recent git repo
authorMauro Meneghin <mauro.meneghin@youview.com>
Fri, 23 Oct 2020 13:43:29 +0000 (14:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 26 Oct 2020 21:34:13 +0000 (22:34 +0100)
The official repo pointed by https://ltrace.org/ hasn't seen any
updates in 5 years, so this commit switches to
https://github.com/dkogan/ltrace from Dima Kogan that includes some
bug fixes, in particular the following commit to avoid a crash:

  192e0a6 void struct members are now ignored

The previous ltrace version gave a crash on a ARMv7 device, showing
this error:

  "Assertion `field_info->type != ARGTYPE_VOID' failed."

Using this commit ltrace shows a '<void>' return value in such cases,
but at least avoids the crash.

Signed-off-by: Mauro Meneghin <mauro.meneghin@youview.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ltrace/ltrace.hash
package/ltrace/ltrace.mk

index f795f53bfb4a9f97edb240cd455c49e26f383de5..a677ed3511588cb0fe55155b8dfa0b65a4aed117 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  894333bb7d347066c4e398d9f4a202af5f2faf80754905dd0e6a2259695baba0  ltrace-c22d359433b333937ee3d803450dc41998115685.tar.gz
+sha256  4aecf69e4a33331aed1e50ce4907e73a98cbccc4835febc3473863474304d547  ltrace-82c66409c7a93ca6ad2e4563ef030dfb7e6df4d4.tar.gz
 sha256  e6d6a009505e345fe949e1310334fcb0747f28dae2856759de102ab66b722cb4  COPYING
index 2eb60fe450e00ac2ff7c17918595c5dc7dbf7c1c..b3bd90daaa707c9ced37b758f3d8b9c55ccd2421 100644 (file)
@@ -4,15 +4,11 @@
 #
 ################################################################################
 
-LTRACE_VERSION = c22d359433b333937ee3d803450dc41998115685
-#LTRACE_SITE = git://anonscm.debian.org/collab-maint/ltrace.git
-
-# Upstream is dead: the git reporistory for ltrace did not follow during the
-# migration from alioth to gitlab, and there is no longer any official
-# upstream repository with the expected sha1, except for the tarball cached on
-# s.b.o., so we go fetch it there.
-LTRACE_SITE = http://sources.buildroot.org/ltrace
-
+# This github version has some extra fixes on top of https://ltrace.org/
+# in particular the following commit to avoid a crash:
+#   192e0a6 void struct members are now ignored
+LTRACE_VERSION = 82c66409c7a93ca6ad2e4563ef030dfb7e6df4d4
+LTRACE_SITE = $(call github,dkogan,ltrace,$(LTRACE_VERSION))
 LTRACE_DEPENDENCIES = elfutils
 LTRACE_CONF_OPTS = --disable-werror
 LTRACE_LICENSE = GPL-2.0