blktrace: really fix parallel build issue
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 20:56:14 +0000 (21:56 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 20:56:14 +0000 (21:56 +0100)
Fixes:
http://autobuild.buildroot.net/results/dd4/dd47b3ca17bdb597d6b12de6b381cf5f25abaf71/
http://autobuild.buildroot.net/results/a84/a842234fbdc8f65d48089b90ee23523540a7091f/
http://autobuild.buildroot.net/results/e63/e6351692ad6aef397e68ffdf107f3a85e4490015/

And many more.

Commit a21163aed (package/blktrace: do not build in parallel) tried to fix
the parallel build issue, but the package doesn't use the autotools package
infrastructure so BLKTRACE_MAKE isn't used.  Instead replace the explicit
$(MAKE) calls with $(MAKE1).

Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/blktrace/blktrace.mk

index 8f3dbab7677dbb866666e2d348d3b73649f54c7f..c193375bf856aeb26c3c1470a73b9d2985136497 100644 (file)
@@ -10,14 +10,12 @@ BLKTRACE_DEPENDENCIES = libaio
 BLKTRACE_LICENSE = GPLv2+
 BLKTRACE_LICENSE_FILES = COPYING
 
-BLKTRACE_MAKE = $(MAKE1)
-
 define BLKTRACE_BUILD_CMDS
-       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+       $(MAKE1) -C $(@D) $(TARGET_CONFIGURE_OPTS)
 endef
 
 define BLKTRACE_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) install \
+       $(MAKE1) -C $(@D) $(TARGET_CONFIGURE_OPTS) install \
                DESTDIR=$(TARGET_DIR) prefix=/usr
 endef