dvb-apps: fix static linking with libiconv
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 27 May 2014 09:27:23 +0000 (11:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 27 May 2014 09:27:23 +0000 (11:27 +0200)
Fixes http://autobuild.buildroot.net/results/4b5/4b56b89dd0ccd3b7e4017782e8d48b9c71207ff7/

Pass the libraries to be linked in LDLIBS instead of LDFLAGS so the end up
after the object files on the linker command line.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dvb-apps/dvb-apps.mk

index 2a35d293f6f5edc63bd2a2530f4bf2940c243812..98ff7eb31e54268628fa708ae09da415373c2aea 100644 (file)
@@ -10,17 +10,15 @@ DVB_APPS_SITE_METHOD = hg
 DVB_APPS_LICENSE = GPLv2 GPLv2+ LGPLv2.1+
 DVB_APPS_LICENSE_FILES = COPYING COPYING.LGPL
 
-DVB_APPS_LDFLAGS = $(TARGET_LDFLAGS)
-
 ifeq ($(BR2_ENABLE_LOCALE),)
 DVB_APPS_DEPENDENCIES = libiconv
-DVB_APPS_LDFLAGS += -liconv
+DVB_APPS_LDLIBS += -liconv
 endif
 
 DVB_APPS_INSTALL_STAGING = YES
 
 define DVB_APPS_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) LDFLAGS="$(DVB_APPS_LDFLAGS)" \
+       $(TARGET_CONFIGURE_OPTS) LDLIBS="$(DVB_APPS_LDLIBS)" \
                $(MAKE) -C $(@D) CROSS_ROOT=$(STAGING_DIR) V=1
 endef