sconeserver: fix imagemagick build failures
authorSimon Dawson <spdawson@gmail.com>
Thu, 6 Dec 2012 05:12:50 +0000 (05:12 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 00:10:11 +0000 (01:10 +0100)
The sconeserver configure script uses Magick++-config to obtain compiler and
linker arguments for the imagemagick libraries. This doesn't work in
Buildroot, and causes build failures such as the following

  http://autobuild.buildroot.net/results/7833edd60bbb2c291aea1efb5ccf407da7f4a51f/build-end.log

The upstream sconeserver code has been changed to use pkg-config directly,
instead of Magick++-config; this patch adapts the sconeserver package to
the upstream change.

Both this patch and the associated upstream change are based on a Buildroot
patch submitted by Samuel Martin: http://patchwork.ozlabs.org/patch/200901/

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sconeserver/sconeserver.mk

index 15a1edc775be4010ec96a4c17d247a6adf543959..ab3d1fc99cb25786e46272273717ae48fc3e51c1 100644 (file)
@@ -5,7 +5,7 @@
 #############################################################
 # Release 0.6.0 doesn't build cleanly, so use a recent
 # Subversion trunk snapshot.
-SCONESERVER_VERSION = 180
+SCONESERVER_VERSION = 183
 SCONESERVER_SITE = \
        https://sconeserver.svn.sourceforge.net/svnroot/sconeserver/trunk
 SCONESERVER_SITE_METHOD = svn
@@ -51,7 +51,7 @@ else
 endif
 
 ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
-       SCONESERVER_DEPENDENCIES += imagemagick
+       SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
        SCONESERVER_CONF_OPT += --with-sconesite-image
 else
        SCONESERVER_CONF_OPT += --without-sconesite-image