package/dbus: use /run for runtime data
authorNorbert Lange <nolange79@gmail.com>
Fri, 17 Jul 2020 21:55:20 +0000 (23:55 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 18 Jul 2020 19:37:36 +0000 (21:37 +0200)
All init systems supported by Buildroot have a /run directory and have
a symlink for /var/run -> /run.

Use the /run directory directly.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/dbus/S30dbus
package/dbus/dbus.mk

index 52646cea2f4ab4c7391cbafbe99454734c8624f0..26772755d7b4f0945029267390baf67703514408 100644 (file)
@@ -7,11 +7,11 @@
 #               and other messages. See http://www.freedesktop.org/software/dbus/
 #
 # processname: dbus-daemon
-# pidfile: /var/run/messagebus.pid
+# pidfile: /run/messagebus.pid
 #
 
 # Create needed directories.
-[ -d /var/run/dbus ] || mkdir -p /var/run/dbus
+[ -d /run/dbus ] || mkdir -p /run/dbus
 [ -d /var/lock/subsys ] || mkdir -p /var/lock/subsys
 [ -d /tmp/dbus ] || mkdir -p /tmp/dbus
 
@@ -38,7 +38,7 @@ stop() {
     echo "done"
     if [ $RETVAL -eq 0 ]; then
         rm -f /var/lock/subsys/dbus-daemon
-        rm -f /var/run/messagebus.pid
+        rm -f /run/messagebus.pid
     fi
 }
 
index 5c2a5fb2cc54758ef9b269b439f3ef6759fbef5b..312c6ba1d890e4b39c55d83016c02a92b1a5a46b 100644 (file)
@@ -15,7 +15,7 @@ define DBUS_PERMISSIONS
 endef
 
 define DBUS_USERS
-       dbus -1 dbus -1 * /var/run/dbus - dbus DBus messagebus user
+       dbus -1 dbus -1 * /run/dbus - dbus DBus messagebus user
 endef
 
 DBUS_DEPENDENCIES = host-pkgconf expat
@@ -27,8 +27,8 @@ DBUS_CONF_OPTS = \
        --disable-xml-docs \
        --disable-doxygen-docs \
        --with-xml=expat \
-       --with-system-socket=/var/run/dbus/system_bus_socket \
-       --with-system-pid-file=/var/run/messagebus.pid
+       --with-system-socket=/run/dbus/system_bus_socket \
+       --with-system-pid-file=/run/messagebus.pid
 
 ifeq ($(BR2_STATIC_LIBS),y)
 DBUS_CONF_OPTS += LIBS='-pthread'