ltp-testsuite: add numactl as optional dependency
authorBaruch Siach <baruch@tkos.co.il>
Wed, 7 Feb 2018 19:04:48 +0000 (21:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 8 Feb 2018 22:12:23 +0000 (23:12 +0100)
Make the detection of libnuma in the configure script consistent when
the numactl package is enabled.

ltp-testsuite does not currently take explicit enable/disable for
libnuma, so none are used. The next ltp-testsuite version will add these
options.

Cc: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ltp-testsuite/ltp-testsuite.mk

index 5e0b35d12a22e296cdf12945a6cbbc3412b634df..c47f587836b3d7de5cffb8504eb5f43d8fa83366 100644 (file)
@@ -40,6 +40,13 @@ else
 LTP_TESTSUITE_CONF_ENV += ac_cv_lib_cap_cap_compare=no
 endif
 
+# No explicit enable/disable options
+ifeq ($(BR2_PACKAGE_NUMACTL),y)
+LTP_TESTSUITE_DEPENDENCIES += numactl
+else
+LTP_TESTSUITE_CONF_ENV += have_numa_headers=no
+endif
+
 # ltp-testsuite uses <fts.h>, which isn't compatible with largefile
 # support.
 LTP_TESTSUITE_CFLAGS = $(filter-out -D_FILE_OFFSET_BITS=64,$(TARGET_CFLAGS))