toolchain-external: move the sysroot check to helper function
authorRomain Naour <romain.naour@gmail.com>
Wed, 27 Apr 2016 20:15:02 +0000 (22:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 27 Apr 2016 20:18:35 +0000 (22:18 +0200)
The sysroot toolchain support check is duplicated at two locations in
the external toolchain infra. So move it inside the
check_unusable_toolchain helper that is called when the toolchain
package is configured (TOOLCHAIN_EXTERNAL_CONFIGURE_CMDS).

The check in TOOLCHAIN_EXTERNAL_INSTALL_SYSROOT_LIBS can be safely
removed since it's already done in check_unusable_toolchain helper.

The check in TOOLCHAIN_EXTERNAL_INSTALL_TARGET_LIBS was removed by
2a87b64f8e8a832a351f8552eb032e4b18431949.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk
toolchain/toolchain-external/toolchain-external.mk

index 8aaad67988f845db14194f0ce4b97833e6958243..4548eded354f9452947d4d30091c6f9904bb7b6d 100644 (file)
@@ -376,6 +376,11 @@ check_unusable_toolchain = \
        if test "$${libc_a_path}" = "libc.a" ; then \
                echo "Unable to detect the toolchain sysroot, Buildroot cannot use this toolchain." ; \
                exit 1 ; \
+       fi ; \
+       sysroot_dir="$(call toolchain_find_sysroot,$${__CROSS_CC})" ; \
+       if test -z "$${sysroot_dir}" ; then \
+               echo "External toolchain doesn't support --sysroot. Cannot use." ; \
+               exit 1 ; \
        fi
 
 #
index 2620fb8275faa33dba670e7fea457cdf32cb25b9..2422b6d02f1289bf0a66a66b276f6b8268f4b7dc 100644 (file)
@@ -493,17 +493,13 @@ $$(printf $(call toolchain_find_libc_a,$(1)) | sed -r -e 's:.*/(usr/)?(lib(32|64
 endef
 
 # Checks for an already installed toolchain: check the toolchain
-# location, check that it supports sysroot, and then verify that it
+# location, check that it is usable, and then verify that it
 # matches the configuration provided in Buildroot: ABI, C++ support,
 # kernel headers version, type of C library and all C library features.
 define TOOLCHAIN_EXTERNAL_CONFIGURE_CMDS
        $(Q)$(call check_cross_compiler_exists,$(TOOLCHAIN_EXTERNAL_CC))
        $(Q)$(call check_unusable_toolchain,$(TOOLCHAIN_EXTERNAL_CC))
        $(Q)SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC))" ; \
-       if test -z "$${SYSROOT_DIR}" ; then \
-               @echo "External toolchain doesn't support --sysroot. Cannot use." ; \
-               exit 1 ; \
-       fi ; \
        $(call check_kernel_headers_version,\
                $(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC)),\
                $(call qstrip,$(BR2_TOOLCHAIN_HEADERS_AT_LEAST))); \
@@ -654,10 +650,6 @@ endif
 
 define TOOLCHAIN_EXTERNAL_INSTALL_SYSROOT_LIBS
        $(Q)SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC))" ; \
-       if test -z "$${SYSROOT_DIR}" ; then \
-               @echo "External toolchain doesn't support --sysroot. Cannot use." ; \
-               exit 1 ; \
-       fi ; \
        ARCH_SYSROOT_DIR="$(call toolchain_find_sysroot,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS))" ; \
        ARCH_LIB_DIR="$(call toolchain_find_libdir,$(TOOLCHAIN_EXTERNAL_CC) $(TOOLCHAIN_EXTERNAL_CFLAGS))" ; \
        SUPPORT_LIB_DIR="" ; \