package/config: really clean
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Sun, 9 May 2010 13:19:10 +0000 (15:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 22 May 2010 20:11:19 +0000 (22:11 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/config/Makefile.kconfig

index 6974cc3b5e6c6b4bddf09e2ef89bf5a0ea1741b8..6d89e597e6ec41229870139f01d94517f9f2ae18 100644 (file)
@@ -149,10 +149,15 @@ ifeq ($(gconf-target),1)
 gconf-objs     := gconf.o kconfig_load.o zconf.tab.o
 endif
 
-clean-files    := lkc_defs.h qconf.moc .tmp_qtcheck \
-                  .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
-clean-files     += mconf qconf gconf
-clean-files     += config.pot linux.pot
+clean-files := lkc_defs.h qconf.moc .tmp_qtcheck \
+               .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
+clean-files += config.pot linux.pot
+clean-files += conf $(conf-objs)
+clean-files += mconf $(mconf-objs)
+clean-files += qconf qconf.o
+clean-files += gconf gconf.o
+clean-files += kconfig_load.o zconf.tab.o
+clean-files += $(kxgettext-objs)
 
 # Check that we have the required ncurses stuff installed for lxdialog (menuconfig)
 PHONY += $(obj)/dochecklxdialog