domoticz: remove boost hack for powerpc64le
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 24 Jun 2018 14:15:05 +0000 (16:15 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 24 Jun 2018 21:53:20 +0000 (23:53 +0200)
Since boost 1.67, seed_rng.hpp has been removed:
https://github.com/boostorg/uuid/commit/a8a1ec3d826b04d2c842e79ecd18cff6a991fd29

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/domoticz/domoticz.mk

index af5856343661f4760bc2d8dc00f00708d66f6dee..6421fd0dd559ac8e2f5375e5bed685c74d447591 100644 (file)
@@ -18,21 +18,6 @@ DOMOTICZ_DEPENDENCIES = \
        sqlite \
        zlib
 
-# Fixes:
-# http://autobuild.buildroot.org/results/454c0ea393615bae2d1b44be9920f25b5c49fc33
-# There is an issue with powerpc64le and boost::uuids::random_generator on the
-# following line of code (from include/boost/uuid/seed_rng.hpp):
-# sha.process_bytes( (unsigned char const*)&std::rand, sizeof( void(*)() ) )
-# This line "inspects the first couple bytes (here eight) of the std::rand
-# function to seed some rng. Due to the implementation of process_bytes and
-# inlining happening, it seems that one of the loops therein uses &rand-1 as
-# some boundary, compiling with -O0 makes that reloc come out as 'rand + 0' and
-# the link will succeed."
-# See: https://bugzilla.suse.com/show_bug.cgi?id=955832#c7
-ifeq ($(BR2_powerpc64le),y)
-DOMOTICZ_CXXFLAGS += -O0
-endif
-
 # Due to the dependency on mosquitto, domoticz depends on
 # !BR2_STATIC_LIBS so set USE_STATIC_BOOST to OFF
 DOMOTICZ_CONF_OPTS += -DUSE_STATIC_BOOST=OFF