xorg: use BR2_PACKAGE_XORG instead of BR2_PACKAGE_XSERVER_none
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2009 13:42:40 +0000 (15:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Jul 2009 21:26:47 +0000 (23:26 +0200)
The BR2_PACKAGE_XSERVER_none option has gone, so use BR2_PACKAGE_XORG7
instead. It is more logical to test if BR2_PACKAGE_XORG7 is set to
know if an X.org server is available, than testing if
BR2_PACKAGE_XSERVER_none is set to know if an X.org server is *not*
available.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/atk/atk.mk
package/cairo/cairo.mk
package/cups/cups.mk
package/directfb/Config.in
package/games/lxdoom/Config.in
package/java/classpath/classpath.mk
package/java/jamvm/jamvm.mk
package/libgtk2/libgtk2.mk
package/pango/pango.mk
package/xpdf/xpdf.mk

index 199ec7d5cc5ae1723ad950108b8d97ff0485843d..2d3a4e5afcc667ed6f844259bcdf2bd7c362fc7a 100644 (file)
@@ -45,7 +45,7 @@ ATK_CONF_OPT =  --enable-shared \
                --disable-glibtest --enable-explicit-deps=no \
                --disable-debug
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
 ATK_CONF_OPT += --with-x \
                --x-includes=$(STAGING_DIR)/usr/include/X11 \
                --x-libraries=$(STAGING_DIR)/usr/lib --disable-glibtest
index 048351e50e1dc89ef2e55abadedc98cdc1eaf072..7a7e532db20d2da709ceecb845f6fba56ce8e0ac 100644 (file)
@@ -48,7 +48,7 @@ else
        CAIRO_CONF_OPT += --disable-directfb
 endif
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        CAIRO_CONF_OPT += --enable-xlib --with-x
        CAIRO_DEPENDENCIES += $(XSERVER)
 else
index 9051e0d0fa7338b52ccf1d6ce34d556a0a525c6d..a22651fc7e5ef89c2b67a83c892a247c819e0331 100644 (file)
@@ -18,7 +18,7 @@ else
        CUPS_CONF_OPT += --disable-dbus
 endif
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        CUPS_DEPENDENCIES += xlib_libX11
 endif
 
index 1f081744abae32181200fdc6a06df31cdfec1740..fce9ed46cce3e49ae9069932610cb412a63798e0 100644 (file)
@@ -16,7 +16,7 @@ config BR2_PACKAGE_DIRECTFB_MULTI
 config BR2_PACKAGE_DIRECTFB_XSERVER
        bool "build with X server backend"
        depends on BR2_PACKAGE_DIRECTFB
-       depends on !BR2_PACKAGE_XSERVER_none
+       depends on BR2_PACKAGE_XORG7
 
 config BR2_PACKAGE_DIRECTFB_UNIQUE
        bool "enable unique window manager"
index 8eb7d52807313858455c3fa50bf9ad1f6e4bfb62..ebef9f5e60942e716d1cf9db1da1d099fbcaf230 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_LXDOOM
        bool "lxdoom"
-       depends on !BR2_PACKAGE_XSERVER_none
+       depends on BR2_PACKAGE_XORG7
        help
          This is the linux version of the popular doom game.
index 71c18a045c7557c3b195911dc9bbb2e56d4dbf4c..b62e29c1b4b048a9fa2fd4de604a6edfafca12a7 100644 (file)
@@ -77,7 +77,7 @@ else
        CLASSPATH_CONF_OPT+= --disable-gtk-peer
 endif
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        CLASSPATH_DEPENDENCIES+= $(XSERVER)
        CLASSPATH_CONF_OPT+= --with-x \
                --x-includes=$(STAGING_DIR)/usr/include/X11 \
index dff089af4d18df84c0b419e8492812da0d519b75..92ae4a6d72c4cecab0fecc4e0d3b6789ffad88cb 100644 (file)
@@ -52,7 +52,7 @@ JAMVM_CONF_OPT = \
 JAMVM_DEPENDENCIES = uclibc host-pkgconfig classpath
 
 #Include X libraries when we have an X server
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        JAMVM_DEPENDENCIES+= $(XSERVER)
        JAMVM_CONF_OPT+= --with-x \
                --x-includes=$(STAGING_DIR)/usr/include/X11 \
index 7db0067bbd5d6d43a2aa14494a480198c1c51652..5c9e542042791d21049d3980a07f4b069cc0a518 100644 (file)
@@ -85,7 +85,7 @@ ifeq ($(BR2_PACKAGE_DIRECTFB),y)
        LIBGTK2_DEPENDENCIES += directfb
 endif
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        LIBGTK2_CONF_OPT += \
                --with-x \
                --x-includes=$(STAGING_DIR)/usr/include/X11 \
index c1aac86bde26be82695c95ac7bfdcd5211ddae10..8cccae65f7959ee75876b535cc0d57da7ab1b4a9 100644 (file)
@@ -40,7 +40,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
                ac_use_included_regex=no gl_cv_c_restrict=no \
                ac_cv_path_FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
         PANGO_CONF_OPT_X = --with-x \
                --x-includes=$(STAGING_DIR)/usr/include/X11 \
                --x-libraries=$(STAGING_DIR)/usr/lib --disable-glibtest
@@ -85,7 +85,7 @@ $(STAMP_DIR)/host_pango_configured: $(STAMP_DIR)/host_pango_unpacked $(STAMP_DIR
                --prefix="$(HOST_DIR)/usr" \
                --sysconfdir="$(HOST_DIR)/etc" \
                --disable-static \
-               $(if $(BR2_PACKAGE_XSERVER_none),--without-x,--with-x) \
+               $(if $(BR2_PACKAGE_XORG7),--with-x,--without-x) \
                --disable-debug \
        )
        touch $@
index 1fbe7110e55ee90b5bfea9cd4a71ec30656d0612..1f09a9d50389aa96312c8a93c12d0f6de8fd150f 100644 (file)
@@ -17,7 +17,7 @@ ifeq ($(BR2_SOFT_FLOAT),y)
        XPDF_CONF_OPT += --enable-fixedpoint
 endif
 
-ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ifeq ($(BR2_PACKAGE_XORG7),y)
        XPDF_DEPENDENCIES += $(XSERVER) openmotif
        XPDF_CONF_OPT += --with-Xm-library=$(STAGING_DIR)/usr/lib --with-Xm-includes=$(STAGING_DIR)/usr/include/Xm \
                                        --with-x --with-freetype2-includes=$(STAGING_DIR)/usr/include \