rfkill: remove package
authorCarlos Santos <casantos@datacom.ind.br>
Sat, 21 Oct 2017 22:30:18 +0000 (20:30 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 3 Nov 2017 16:21:14 +0000 (17:21 +0100)
The rfkill program has been incorporated to the util-linux package.

The new implementation is based upon, and backward compatible with, the
original rfkill from Johannes Berg and Marcel Holtmann.

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
DEVELOPERS
package/Config.in
package/aircrack-ng/Config.in
package/rfkill/Config.in [deleted file]
package/rfkill/rfkill.hash [deleted file]
package/rfkill/rfkill.mk [deleted file]

index c9300831febce4fc450a0e9c0b6aab6afcb30318..35a6d6e1fe7405980161ab472af16fbd71c62ce5 100644 (file)
@@ -145,6 +145,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.11"
 
+config BR2_PACKAGE_RFKILL
+       bool "rfkill package removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_UTIL_LINUX
+       select BR2_PACKAGE_UTIL_LINUX_RFKILL
+       help
+         The rfkill program is now provided by the util-linux package.
+
 config BR2_PACKAGE_UTIL_LINUX_RESET
        bool "util-linux reset option removed"
        select BR2_LEGACY
index caf1d7c71250268106a2cfd491b8036b8b747e8b..b357693a924d8ceb68d9544712c87bfe10d3dd26 100644 (file)
@@ -1640,7 +1640,6 @@ N:        Vinicius Tinti <viniciustinti@gmail.com>
 F:     package/python-thrift/
 
 N:     Volkov Viacheslav <sv99@inbox.ru>
-F:     package/rfkill/
 F:     package/v4l2grab/
 F:     package/zbar/
 
index dbfb288d530d1f579dc13aed85995278c7d89294..28444f64deace7c6bb63bd180d672bcd05511498 100644 (file)
@@ -477,7 +477,6 @@ endmenu
        source "package/pru-software-support/Config.in"
        source "package/pulseview/Config.in"
        source "package/read-edid/Config.in"
-       source "package/rfkill/Config.in"
        source "package/rng-tools/Config.in"
        source "package/rpi-userland/Config.in"
        source "package/rs485conf/Config.in"
index 2164ad40703fa9d00ee559ccc28b12f54e5f25b7..12fda1cbf2aadb0d5e96d72c46da5b257f7c06ef 100644 (file)
@@ -11,8 +11,8 @@ config BR2_PACKAGE_AIRCRACK_NG
        help
          A set of tools for auditing wireless networks
 
-         For complete functionality, also select ethtool, iw, rfkill,
-         util-linux utilities, and wireless_tools.
+         For complete functionality, also select ethtool, iw,
+         util-linux (utilities and rfkill), and wireless_tools.
 
          http://www.aircrack-ng.org/
 
diff --git a/package/rfkill/Config.in b/package/rfkill/Config.in
deleted file mode 100644 (file)
index 0d07913..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_RFKILL
-       bool "rfkill"
-       help
-         rfkill is a small userspace tool to query the state of the
-         rfkill switches.
-
-         https://wireless.wiki.kernel.org/en/users/documentation/rfkill
diff --git a/package/rfkill/rfkill.hash b/package/rfkill/rfkill.hash
deleted file mode 100644 (file)
index 21be0a2..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# From: https://www.kernel.org/pub/software/network/rfkill/sha256sums.asc
-sha256 e0ae3004215e39a6c5c36e0726558740728d16f67ebdb8bea621250f6091d86a  rfkill-0.5.tar.xz
diff --git a/package/rfkill/rfkill.mk b/package/rfkill/rfkill.mk
deleted file mode 100644 (file)
index 2f9fe9f..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-################################################################################
-#
-# rfkill
-#
-################################################################################
-
-RFKILL_VERSION = 0.5
-RFKILL_SOURCE = rfkill-$(RFKILL_VERSION).tar.xz
-RFKILL_SITE = https://www.kernel.org/pub/software/network/rfkill
-RFKILL_LICENSE = ISC
-RFKILL_LICENSE_FILES = COPYING
-
-define RFKILL_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
-               VERSION_SUFFIX="br"
-endef
-
-define RFKILL_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))