git: new package
authorSagaert Johan <sagaert.johan@skynet.be>
Sun, 26 May 2013 09:38:32 +0000 (09:38 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 26 May 2013 21:26:49 +0000 (23:26 +0200)
[Peter: needs largefile, fix license info]
Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/git/Config.in [new file with mode: 0644]
package/git/git.mk [new file with mode: 0644]

index de84d46cd0245dcc1c0ea7c55812483f32046e92..52a0735203066fdbe879db6e7f16aff9b6095802 100644 (file)
@@ -74,6 +74,7 @@ source "package/gawk/Config.in"
 endif
 source "toolchain/gcc/Config.in.2"
 source "package/gettext/Config.in"
+source "package/git/Config.in"
 source "package/gperf/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/grep/Config.in"
diff --git a/package/git/Config.in b/package/git/Config.in
new file mode 100644 (file)
index 0000000..31e5ffe
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_GIT
+       bool "git"
+       depends on BR2_LARGEFILE
+       help
+         Git is a free and open source distributed version control system
+         designed to handle everything from small to very large projects.
+
+         http://git-scm.com
+
+comment "git requires a toolchain with LARGEFILE support"
+       depends on !BR2_LARGEFILE
diff --git a/package/git/git.mk b/package/git/git.mk
new file mode 100644 (file)
index 0000000..408456b
--- /dev/null
@@ -0,0 +1,63 @@
+#############################################################
+#
+# git
+#
+#############################################################
+
+GIT_VERSION         = 1.8.3
+GIT_SITE            = http://git-core.googlecode.com/files/
+GIT_LICENSE         = GPLv2 LGPLv2.1+
+GIT_LICENSE_FILES   = COPYING LGPL-2.1
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+       GIT_DEPENDENCIES += zlib
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+       GIT_DEPENDENCIES += openssl
+       GIT_CONF_OPT += --with-openssl
+else
+       GIT_CONF_OPT += --without-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_PERL),y)
+       GIT_DEPENDENCIES += perl
+       GIT_CONF_OPT += --with-libpcre
+else
+       GIT_CONF_OPT += --without-libpcre
+endif
+
+ifeq ($(BR2_PACKAGE_CURL),y)
+       GIT_DEPENDENCIES += curl
+       GIT_CONF_OPT += --with-curl
+else
+       GIT_CONF_OPT += --without-curl
+endif
+
+ifeq ($(BR2_PACKAGE_EXPAT),y)
+       GIT_DEPENDENCIES += expat
+       GIT_CONF_OPT += --with-expat
+else
+       GIT_CONF_OPT += --without-expat
+endif
+
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+       GIT_DEPENDENCIES += libiconv
+       GIT_CONF_OPT += --with-iconv=/usr/lib
+else
+       GIT_CONF_OPT += --without-iconv
+endif
+
+ifeq ($(BR2_PACKAGE_TCL),y)
+       GIT_DEPENDENCIES += tcl
+       GIT_CONF_OPT += --with-tcltk
+else
+       GIT_CONF_OPT += --without-tcltk
+endif
+
+# assume yes for these tests, configure will bail out otherwise
+# saying error: cannot run test program while cross compiling
+GIT_CONF_ENV =         ac_cv_fread_reads_directories=yes \
+       ac_cv_snprintf_returns_bogus=yes
+
+$(eval $(autotools-package))