package/linux-headers: add comment to safely ignore missing cross-compiler
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Feb 2014 14:35:18 +0000 (15:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 23 Feb 2014 15:34:53 +0000 (16:34 +0100)
For some architectures (eg. Arc, Cris, Hexagon, ia64, Parisc, Score and
Xtensa), the Linux buildsystem tries to call the cross-compiler when
installing the headers.

This is a spurious call, since a cross-compiler is not needed at all to
install the headers.

As some users have reported the issue, just add a comment in linux-headers.mk
directing the user to ignore those errors.

Reported-by: Noam Camus <noamc@ezchip.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-headers/linux-headers.mk

index 30d3076592d0e84216de4f9ba3af7bf66cc9b7ab..086e5d5704d1a3e400225236cdaa5cf80e4721ef 100644 (file)
@@ -17,6 +17,12 @@ LINUX_HEADERS_SOURCE = linux-$(LINUX_HEADERS_VERSION).tar.xz
 
 LINUX_HEADERS_INSTALL_STAGING = YES
 
+# For some architectures (eg. Arc, Cris, Hexagon, ia64, parisc,
+# score and xtensa), the Linux buildsystem tries to call the
+# cross-compiler, although it is not needed at all.
+# This results in seemingly errors like:
+#   [...]/scripts/gcc-version.sh: line 26: arc-linux-uclibc-gcc: command not found
+# Those can be safely ignored.
 define LINUX_HEADERS_INSTALL_STAGING_CMDS
        (cd $(@D); \
                $(TARGET_MAKE_ENV) $(MAKE) \