qtopia4: add option for STL support
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Jul 2009 12:16:25 +0000 (14:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Jul 2009 12:16:25 +0000 (14:16 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qtopia4/Config.in
package/qtopia4/qtopia4.mk

index 05243125770660693a14025a2fdc6cbe7f75fad7..457b9399a46b71fd331cf6cf07ca201c287c9cc8 100644 (file)
@@ -310,6 +310,12 @@ config BR2_PACKAGE_QTOPIA4_WEBKIT
          Build the WebKit module.
          If unsure, say n.
 
+config BR2_PACKAGE_QTOPIA4_STL
+       bool "STL support"
+       help
+         Compile STL support.
+         If unsure, say n.
+
 config BR2_PACKAGE_QTOPIA4_OPENSSL
        bool "Enable OpenSSL support"
        depends on BR2_PACKAGE_QTOPIA4_NETWORK
index f7196f476876b20f6e617d70e3a34e9ec5182d8f..0d2b980e97d97b2a76405fd6ef3fd2e0a99d95c6 100644 (file)
@@ -323,6 +323,12 @@ else
 QTOPIA4_CONFIGURE+= -no-webkit
 endif
 
+ifeq ($(BR2_PACKAGE_QTOPIA4_STL),y)
+QTOPIA4_CONFIGURE+= -stl
+else
+QTOPIA4_CONFIGURE+= -no-stl
+endif
+
 QTOPIA4_CONFIGURE:=$(strip $(subst ",, $(QTOPIA4_CONFIGURE)))
 #"))
 BR2_PACKAGE_QTOPIA4_EMB_PLATFORM:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM)))
@@ -460,7 +466,6 @@ endif
                -embedded $(BR2_PACKAGE_QTOPIA4_EMB_PLATFORM) \
                $(QTOPIA4_QCONFIG_COMMAND) \
                $(QTOPIA4_CONFIGURE) \
-               -no-stl \
                -no-cups \
                -no-nis \
                -no-accessibility \