package/systemd: add optional support for importd
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:09 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 10:38:29 +0000 (12:38 +0200)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index d9f31b66c92098a1a3ce746085cac283f3c2a670..d8e6eba14911e2c40e36b7c66fa94301a56a70f7 100644 (file)
@@ -201,6 +201,21 @@ config BR2_PACKAGE_SYSTEMD_MACHINED
 
          http://www.freedesktop.org/software/systemd/man/systemd-machined.service.html
 
+config BR2_PACKAGE_SYSTEMD_IMPORTD
+       bool "enable import daemon"
+       select BR2_PACKAGE_LIBCURL
+       select BR2_PACKAGE_LIBGCRYPT
+       select BR2_PACKAGE_BZIP2
+       select BR2_PACKAGE_LZ4
+       select BR2_PACKAGE_XZ
+       select BR2_PACKAGE_ZLIB
+       help
+         systemd-importd is a system service that manages virtual
+         machine and container images for systemd-machined and
+         machinectl.
+
+         http://www.freedesktop.org/software/systemd/man/machinectl.html#Image%20Transfer%20Commands
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index 44a22a930735a6a52a40148c1981c80e1944fc73..8bcbcf8719d47977187fea5a0e00b17135a4bb83 100644 (file)
@@ -207,6 +207,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-machined
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_IMPORTD),y)
+SYSTEMD_CONF_OPTS += --enable-importd
+else
+SYSTEMD_CONF_OPTS += --disable-importd
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK