samba4: install to staging
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 6 Mar 2015 12:50:29 +0000 (09:50 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 6 Mar 2015 22:50:17 +0000 (23:50 +0100)
It's required for packages that need libsmbclient.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba4/samba4.mk

index 527d584f17e75c6cc0a11949502c0bfc476a547c..78d92ef39199b281a606fa636f42294c9e877ffa 100644 (file)
@@ -7,6 +7,7 @@
 SAMBA4_VERSION = 4.2.0
 SAMBA4_SITE = http://ftp.samba.org/pub/samba
 SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
+SAMBA4_INSTALL_STAGING = YES
 SAMBA4_LICENSE = GPLv3+
 SAMBA4_LICENSE_FILES = COPYING
 SAMBA4_DEPENDENCIES = host-e2fsprogs host-heimdal e2fsprogs popt python zlib \
@@ -113,6 +114,10 @@ define SAMBA4_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
 endef
 
+define SAMBA4_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
+endef
+
 define SAMBA4_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
 endef