dash: bump to version 0.5.7-2 and style cleanup
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 15 Oct 2011 03:07:23 +0000 (00:07 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Oct 2011 21:06:09 +0000 (23:06 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch [deleted file]
package/dash/dash-0.5.7-no-config.h-for-helpers.patch [new file with mode: 0644]
package/dash/dash.mk

diff --git a/package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch b/package/dash/dash-0.5.5.1-no-config.h-for-helpers.patch
deleted file mode 100644 (file)
index 9fd449c..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-[PATCH] Don't include config.h when building helpers using the native compiler
-
-config.h contains settings for the cross compiler (most importantly
-32/64bit versions of functions), so don't include it when calling the
-native compiler to build the helpers.
-
-Otherwise we get build errors like:
-
-/usr/bin/gcc -include ../config.h -DBSD=1 -DSHELL -DIFS_BROKEN  -g -O2 -Wall    -o mkinit mkinit.c
-In file included from /usr/include/sys/stat.h:107,
-                 from /usr/include/fcntl.h:38,
-                 from mkinit.c:50:
-/usr/include/bits/stat.h:117: error: redefinition of ‘struct stat’
-In file included from /usr/include/fcntl.h:38,
-                 from mkinit.c:50:
-/usr/include/sys/stat.h:504: error: redefinition of ‘stat’
-/usr/include/sys/stat.h:455: note: previous definition of ‘stat’ was here
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- src/Makefile.in |    1 -
- 1 file changed, 1 deletion(-)
-
-Index: dash-0.5.5.1/src/Makefile.in
-===================================================================
---- dash-0.5.5.1.orig/src/Makefile.in
-+++ dash-0.5.5.1/src/Makefile.in
-@@ -165,7 +165,6 @@ COMMON_CPPFLAGS = \
- AM_CFLAGS = $(COMMON_CFLAGS)
- AM_CPPFLAGS = $(COMMON_CPPFLAGS)
- AM_CFLAGS_FOR_BUILD = -g -O2 $(COMMON_CFLAGS) 
--AM_CPPFLAGS_FOR_BUILD = $(COMMON_CPPFLAGS)
- COMPILE_FOR_BUILD = \
-       $(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) \
-       $(AM_CFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD) 
diff --git a/package/dash/dash-0.5.7-no-config.h-for-helpers.patch b/package/dash/dash-0.5.7-no-config.h-for-helpers.patch
new file mode 100644 (file)
index 0000000..9fd449c
--- /dev/null
@@ -0,0 +1,35 @@
+[PATCH] Don't include config.h when building helpers using the native compiler
+
+config.h contains settings for the cross compiler (most importantly
+32/64bit versions of functions), so don't include it when calling the
+native compiler to build the helpers.
+
+Otherwise we get build errors like:
+
+/usr/bin/gcc -include ../config.h -DBSD=1 -DSHELL -DIFS_BROKEN  -g -O2 -Wall    -o mkinit mkinit.c
+In file included from /usr/include/sys/stat.h:107,
+                 from /usr/include/fcntl.h:38,
+                 from mkinit.c:50:
+/usr/include/bits/stat.h:117: error: redefinition of ‘struct stat’
+In file included from /usr/include/fcntl.h:38,
+                 from mkinit.c:50:
+/usr/include/sys/stat.h:504: error: redefinition of ‘stat’
+/usr/include/sys/stat.h:455: note: previous definition of ‘stat’ was here
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/Makefile.in |    1 -
+ 1 file changed, 1 deletion(-)
+
+Index: dash-0.5.5.1/src/Makefile.in
+===================================================================
+--- dash-0.5.5.1.orig/src/Makefile.in
++++ dash-0.5.5.1/src/Makefile.in
+@@ -165,7 +165,6 @@ COMMON_CPPFLAGS = \
+ AM_CFLAGS = $(COMMON_CFLAGS)
+ AM_CPPFLAGS = $(COMMON_CPPFLAGS)
+ AM_CFLAGS_FOR_BUILD = -g -O2 $(COMMON_CFLAGS) 
+-AM_CPPFLAGS_FOR_BUILD = $(COMMON_CPPFLAGS)
+ COMPILE_FOR_BUILD = \
+       $(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) \
+       $(AM_CFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD) 
index db2d4e5a5013cfa5447b6f8c5afb2149bbfd741c..26c6431b65ac719185717e0830caf108e1a7ec35 100644 (file)
@@ -3,10 +3,11 @@
 # dash
 #
 #############################################################
-DASH_VERSION:=0.5.5.1
-DASH_SOURCE:=dash_$(DASH_VERSION).orig.tar.gz
-DASH_SITE:=$(BR2_DEBIAN_MIRROR)/debian/pool/main/d/dash
-DASH_PATCH:=dash_$(DASH_VERSION)-6.diff.gz
+
+DASH_VERSION = 0.5.7
+DASH_SOURCE = dash_$(DASH_VERSION).orig.tar.gz
+DASH_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/d/dash
+DASH_PATCH = dash_$(DASH_VERSION)-2.diff.gz
 
 define DASH_INSTALL_TARGET_CMDS
        cp -a $(@D)/src/dash $(TARGET_DIR)/bin/dash