pango: remove initscript
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Oct 2015 01:11:33 +0000 (22:11 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Oct 2015 07:39:36 +0000 (09:39 +0200)
pango-querymodules is deprecated/removed, so ditch the initscript.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pango/S25pango [deleted file]
package/pango/pango.mk

diff --git a/package/pango/S25pango b/package/pango/S25pango
deleted file mode 100644 (file)
index 9af9307..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-#
-# run pango-querymodules if needed
-
-FILE=/etc/pango/pango.modules
-
-case "$1" in
-     start|"")
-       if [ ! -f $FILE ] ; then
-          mkdir -p /etc/pango
-          /usr/bin/pango-querymodules > "$FILE"
-       fi
-       ;;
-    stop)
-       ;;
-    *)
-       echo "Usage: $0 {start|stop}" >&2
-       exit 1
-       ;;
-esac
\ No newline at end of file
index 19d6509286f37b3397d35df81a9fe2937d95dbb5..6c96cd3633ff27305cc36052e293afc5cf8598ae 100644 (file)
@@ -97,10 +97,5 @@ PANGO_DEPENDENCIES += xlib_libXft xlib_libXrender
 PANGO_CONF_OPTS += --with-xft
 endif
 
-define PANGO_INSTALL_INIT_SYSV
-       $(INSTALL) -m 755 -D package/pango/S25pango \
-               $(TARGET_DIR)/etc/init.d/S25pango
-endef
-
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))