package/open62541: fix library version definition
authorScott Fan <fancp2007@gmail.com>
Sat, 20 Feb 2021 16:27:14 +0000 (00:27 +0800)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 20 Feb 2021 22:12:54 +0000 (23:12 +0100)
Manually specified version must start with letter 'v',
otherwise, the generated version macro will be zero
in the <build_dir>/src_generated/open62541/config.h file:
  #define UA_OPEN62541_VER_MAJOR 0
  #define UA_OPEN62541_VER_MINOR 0
  #define UA_OPEN62541_VER_PATCH 0

Reference from the following link:
https://open62541.org/doc/current/building.html

Signed-off-by: Scott Fan <fancp2007@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/open62541/open62541.mk

index 5a9f27562a75a9be6dc0c8afb5f2a9b5c1943cba..102e09a4297d4806d18d55f6f8c4d9a158c5b4df 100644 (file)
@@ -19,7 +19,7 @@ OPEN62541_LICENSE_FILES = LICENSE
 OPEN62541_CONF_OPTS = \
        -DCMAKE_BUILD_TYPE=Release \
        -DGIT_EXECUTABLE=NO \
-       -DOPEN62541_VERSION=$(OPEN62541_VERSION) \
+       -DOPEN62541_VERSION=v$(OPEN62541_VERSION) \
        -DUA_ENABLE_HARDENING=OFF
 
 ifeq ($(BR2_PACKAGE_OPEN62541_UA_NAMESPACE_ZERO_MINIMAL),y)