c-icap: fix config script
authorGuillaume GARDET <guillaume.gardet@oliseo.fr>
Thu, 23 Jul 2015 08:45:47 +0000 (10:45 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Jul 2015 21:07:40 +0000 (23:07 +0200)
This commit adjusts the c-icap config script by removing a bogus
-L$LIBDIR which was expanded to -L/usr/lib, which is wrong for
cross-compilation. It fixes the build of c-icap-modules:

  http://autobuild.buildroot.org/results/b05/b05141a6d450c94669c6a0a5a0f5b799c2c248f2/

Reported-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Guillaume GARDET <guillaume.gardet@oliseo.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 0f42b6cfb1bdd90cf98878d3a53cae49f59059f8..0e27cc4bbdbee5fd426bf010f65d6fe421e45428 100644 (file)
@@ -57,6 +57,7 @@ define C_ICAP_TUNE_INSTALLATION
                $(STAGING_DIR)/usr/bin/{c-icap,c-icap-libicapapi}-config
        $(SED) 's%INCDIR2=.*%INCDIR2=$(STAGING_DIR)/usr/include/c_icap%' \
                $(STAGING_DIR)/usr/bin/{c-icap,c-icap-libicapapi}-config
+       $(SED) 's%-L$$LIBDIR %%' $(STAGING_DIR)/usr/bin/c-icap-libicapapi-config
 endef
 
 C_ICAP_POST_INSTALL_TARGET_HOOKS += C_ICAP_TUNE_INSTALLATION