avahi: remove useless 'mkdir -p' in AVAHI_INSTALL_INIT_SYSTEMD
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 11:01:04 +0000 (13:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 11:01:04 +0000 (13:01 +0200)
In AVAHI_INSTALL_INIT_SYSTEMD, since we're using 'install -D' to
install /usr/lib/tmpfiles.d/avahi.conf in $(TARGET_DIR), there's no
need to have a 'mkdir -p' before that, since 'install -D' creates the
directories as needed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/avahi/avahi.mk

index cafb2db968a4c51b4b830dcc51d1f5a851ac470a..b684ab7f8c810faeac74c2570a33d73ee07e76a9 100644 (file)
@@ -172,8 +172,6 @@ define AVAHI_INSTALL_INIT_SYSTEMD
        ln -fs /lib/systemd/system/avahi-dnsconfd.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/avahi-dnsconfd.service
 
-       mkdir -p $(TARGET_DIR)/usr/lib/tmpfiles.d
-
        $(INSTALL) -D -m 644 package/avahi/avahi_tmpfiles.conf \
                $(TARGET_DIR)/usr/lib/tmpfiles.d/avahi.conf
 endef