arch/x86: remove support for i386
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Apr 2016 21:31:34 +0000 (23:31 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Apr 2016 21:38:34 +0000 (23:38 +0200)
The Linux kernel doesn't even support i386 anymore, there is no NPTL
support for i386 and uClibc-ng only supports NPTL on x86, so there is
essentially no usable thread implementation. Most likely glibc and
musl also don't support i386 either. So it's time to remove the
support for this architecture variant.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
.defconfig
Config.in.legacy
arch/Config.in.x86
package/openssl/openssl.mk
package/qemu/qemu.mk
package/uclibc/Config.in
toolchain/toolchain-common.in
toolchain/toolchain-external/Config.in

index 585be557d40a37d7f64f2f457e6b17e5d386ccbb..037647e2234c8caf91ac14de2ce919df99a35195 100644 (file)
@@ -19,7 +19,6 @@ BR2_i386=y
 # BR2_sparc is not set
 # BR2_sparc64 is not set
 # BR2_x86_64 is not set
-# BR2_x86_i386 is not set
 # BR2_x86_i486 is not set
 # BR2_x86_i586 is not set
 BR2_x86_i686=y
index 6691c509748e0d2bf961b8bd81b4e5c6e6419588..ba3d94c875629531cf8d1b0111f2b254c9f52b55 100644 (file)
@@ -145,6 +145,12 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.05"
 
+config BR2_x86_i386
+       bool "x86 i386 support removed"
+       help
+         The support for the i386 processors of the x86 architecture
+         has been removed.
+
 config BR2_PACKAGE_QT5WEBKIT_EXAMPLES
        bool "qt5webkit-examples package removed"
        select BR2_LEGACY
index 7be814b8fa7938aef1fe3a234e99d6cb41c0ab49..4039db81765633f6b470f76803a5603aa22d6858 100644 (file)
@@ -25,9 +25,6 @@ choice
        help
          Specific CPU variant to use
 
-config BR2_x86_i386
-       bool "i386"
-       depends on !BR2_x86_64
 config BR2_x86_i486
        bool "i486"
        depends on !BR2_x86_64
@@ -210,7 +207,6 @@ config BR2_x86_winchip2
 endchoice
 
 config BR2_ARCH
-       default "i386"          if BR2_x86_i386
        default "i486"          if BR2_x86_i486
        default "i586"          if BR2_x86_i586
        default "i586"          if BR2_x86_x1000
@@ -246,7 +242,6 @@ config BR2_ENDIAN
        default "LITTLE"
 
 config BR2_GCC_TARGET_ARCH
-       default "i386"          if BR2_x86_i386
        default "i486"          if BR2_x86_i486
        default "i586"          if BR2_x86_i586
        default "i586"          if BR2_x86_x1000
index 30dfe31dd066b3fbda31f12d1276055f88abf81c..3b8e52563ace39525c2868a624800371a81ef4a5 100644 (file)
@@ -53,11 +53,6 @@ ifeq ($(ARCH),x86_64)
 OPENSSL_TARGET_ARCH = x86_64
 endif
 
-# Workaround for bug #3445
-ifeq ($(BR2_x86_i386),y)
-OPENSSL_TARGET_ARCH = generic32 386
-endif
-
 define HOST_OPENSSL_CONFIGURE_CMDS
        (cd $(@D); \
                $(HOST_CONFIGURE_OPTS) \
index 4397367ad5783b18b38e556045bb5273747b7b13..522910eabf685fa471bced619a170aa9686b6c86 100644 (file)
@@ -23,7 +23,6 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-python host-zlib host-libglib2 host-p
 #       arm             arm
 #       armeb           armeb
 #       bfin            not supported
-#       i386            i386
 #       i486            i386
 #       i586            i386
 #       i686            i386
index eac5d05af86d6b9647f9d400662d35ee3f5cac71..efa84e9e85efe775b7a1dfdd1fff985a2b58124f 100644 (file)
@@ -71,7 +71,7 @@ choice
                select BR2_TOOLCHAIN_HAS_THREADS
                select BR2_TOOLCHAIN_HAS_THREADS_NPTL
                depends on BR2_USE_MMU
-               depends on !BR2_m68k && !BR2_x86_i386
+               depends on !BR2_m68k
 endchoice
 
 config BR2_PTHREAD_DEBUG
@@ -176,7 +176,6 @@ config BR2_UCLIBC_POWERPC_TYPE
 config BR2_UCLIBC_X86_TYPE
        string
        depends on BR2_UCLIBC_TARGET_ARCH = "i386"
-       default "386"        if BR2_x86_i386
        default "486"        if BR2_x86_i486
        default "586"        if BR2_x86_i586
        default "586MMX"     if BR2_x86_pentium_mmx
index 0907c5e8303e09cb8ab9be9e256d0519bd99aa5a..7ad1c058258381f18ffc2cd1416f6463ed5b80cf 100644 (file)
@@ -316,7 +316,6 @@ config BR2_TOOLCHAIN_GCC_AT_LEAST
 config BR2_TOOLCHAIN_HAS_SYNC_1
        bool
        default y
-       depends on !BR2_x86_i386
        depends on !BR2_bfin
        depends on !BR2_microblaze
        depends on !BR2_sparc
@@ -330,7 +329,6 @@ config BR2_TOOLCHAIN_HAS_SYNC_4
        bool
        default y
        depends on !BR2_sparc
-       depends on !BR2_x86_i386
        depends on !(BR2_arc && !BR2_ARC_ATOMIC_EXT)
 
 # The availability of __sync for 8-byte types on ARM is somewhat
@@ -362,7 +360,6 @@ config BR2_TOOLCHAIN_X86_HAS_SYNC_8
        bool
        default y
        depends on BR2_i386
-       depends on !BR2_x86_i386
        depends on !BR2_x86_i486
        depends on !BR2_x86_c3
        depends on !BR2_x86_winchip_c6
index ff759a0d9bf29265e9a35d19b5a42076fd4652bd..d6f57a1a5bbec3a0b26c5d93f3741e56ff773d91 100644 (file)
@@ -615,8 +615,7 @@ config BR2_TOOLCHAIN_EXTERNAL_MUSL_CROSS
        bool "Musl 1.1.12 toolchain (experimental)"
        depends on (BR2_arm && BR2_ARM_EABI) || \
                (BR2_arm && BR2_ARM_EABIHF && !BR2_ARM_CPU_ARMV4) || \
-               (BR2_armeb && BR2_ARM_EABI) || \
-               (BR2_i386 && !BR2_x86_i386) || \
+               (BR2_armeb && BR2_ARM_EABI) || BR2_i386 || \
                (BR2_mips && !BR2_SOFT_FLOAT) || \
                BR2_mipsel || (BR2_powerpc && BR2_powerpc_CLASSIC) || \
                BR2_sh4 || BR2_sh4eb || \