microperl: fix build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2009 13:48:40 +0000 (15:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2009 13:48:40 +0000 (15:48 +0200)
Fix the little build systems hacks that no longer applied to the
version of Perl being used. With these fixes in place, microperl
builds and runs properly simple Perl commands on the target.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/microperl/microperl.mk

index 5a41f384d47e0c6e8e69171021d7a4970ed99cb0..f2a958b7aa4b83ea43f28644c3ae2cfb71e3aea8 100644 (file)
@@ -33,8 +33,8 @@ $(MICROPERL_DIR)/.host_configured: $(MICROPERL_DIR)/.source
 
 
 $(MICROPERL_DIR)/.host_configured_and_fixed: $(MICROPERL_DIR)/.host_configured
-       $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/makefile
-       $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/makefile
+       $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/Makefile
+       $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/Makefile
        touch $@
 
 $(MICROPERL_DIR)/.host_make: $(MICROPERL_DIR)/.host_configured_and_fixed
@@ -42,7 +42,6 @@ $(MICROPERL_DIR)/.host_make: $(MICROPERL_DIR)/.host_configured_and_fixed
        touch $@
 
 $(MICROPERL_DIR)/.host_make_fixed: $(MICROPERL_DIR)/.host_make
-       $(SED) 's#^.*<asm/page.h>.*##g' $(MICROPERL_DIR)/ext/IPC/SysV/SysV.c
        $(MAKE) -C $(MICROPERL_DIR) test        || echo "An error is expected on make test"
        touch $@