xconfig: Save the configuration properly in qconf
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Jul 2009 16:21:32 +0000 (18:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2009 14:07:05 +0000 (16:07 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/config/kconfig-to-buildroot2.patch
package/config/qconf.cc

index 5f5d8ee7f8d1724a890415098c95e60874c6dfff..3348b85a136c674551c1c6c122dc135ce241b6f5 100644 (file)
@@ -7,11 +7,11 @@
  gconf.c             |    4 -
  gconf.glade         |    2 
  mconf.c             |   39 +++++++++----------
- qconf.cc            |    -
+ qconf.cc            |    5 +-
  util.c              |  105 +++++++++++++++++++++++++++++++++++++++++++++++++++-
  zconf.tab.c_shipped |    2 
  zconf.y             |    2 
- 12 files changed, 239 insertions(+), 103 deletions(-)
+ 12 files changed, 241 insertions(+), 103 deletions(-)
 
 Index: config/Makefile
 ===================================================================
@@ -741,6 +741,22 @@ Index: config/qconf.cc
        setCaption(title);
  
        width = configSettings->readNumEntry("/window width", d->width() - 64);
+@@ -1612,6 +1611,7 @@
+ {
+       if (!conf_get_changed()) {
+               e->accept();
++              conf_write_autoconf();
+               return;
+       }
+       QMessageBox mb("qconf", _("Save configuration?"), QMessageBox::Warning,
+@@ -1622,6 +1622,7 @@
+       switch (mb.exec()) {
+       case QMessageBox::Yes:
+               conf_write(NULL);
++              conf_write_autoconf();
+       case QMessageBox::No:
+               e->accept();
+               break;
 Index: config/util.c
 ===================================================================
 --- config.orig/util.c
index 3e539c1c7a11baa1513c9eb09d37af40c1642170..9af12a61a37c2620986089deba97a63063e5f8c8 100644 (file)
@@ -1611,6 +1611,7 @@ void ConfigMainWindow::closeEvent(QCloseEvent* e)
 {
        if (!conf_get_changed()) {
                e->accept();
+               conf_write_autoconf();
                return;
        }
        QMessageBox mb("qconf", _("Save configuration?"), QMessageBox::Warning,
@@ -1621,6 +1622,7 @@ void ConfigMainWindow::closeEvent(QCloseEvent* e)
        switch (mb.exec()) {
        case QMessageBox::Yes:
                conf_write(NULL);
+               conf_write_autoconf();
        case QMessageBox::No:
                e->accept();
                break;