qt5base: add rPi EGL glue code
authorFloris Bos <bos@je-eigen-domein.nl>
Tue, 19 Mar 2013 09:29:40 +0000 (09:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 19 Mar 2013 21:41:39 +0000 (22:41 +0100)
When the rpi-userland package is selected, assume we are targetting
the Raspberry Pi, and add the right platform glue code when building
the Qt5 EGLFS plugin.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5base/qt5base-mkspecs-files.patch
package/qt5/qt5base/qt5base.mk

index a86d0b19eccf177489c7ca52b544e4fa38292c67..d5827f600543421712f9d2b5c8483d3c45dcb7fa 100644 (file)
@@ -14,7 +14,7 @@ Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
 ===================================================================
 --- /dev/null
 +++ b/mkspecs/devices/linux-buildroot-g++/qmake.conf
-@@ -0,0 +1,38 @@
+@@ -0,0 +1,41 @@
 +MAKEFILE_GENERATOR      = UNIX
 +CONFIG                  += incremental gdb_dwarf_index
 +QMAKE_INCREMENTAL_STYLE = sublib
@@ -49,6 +49,9 @@ Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
 +
 +QMAKE_LIBS             += -lrt -lpthread -ldl
 +
++# device specific glue code
++EGLFS_PLATFORM_HOOKS_SOURCES =
++
 +# Sanity check
 +deviceSanityCheckCompiler()
 +
index ac63e9814ab67f375f09d81f78edd04243feb859..3b4c007a0bec0edc155a59c16953239abc3df088 100644 (file)
@@ -75,6 +75,10 @@ endif
 ifeq ($(BR2_PACKAGE_QT5BASE_EGLFS),y)
 QT5BASE_CONFIGURE_OPTS += -opengl es2 -eglfs
 QT5BASE_DEPENDENCIES   += libgles libegl
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES = \
+       $(@D)/mkspecs/devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp
+endif
 else
 QT5BASE_CONFIGURE_OPTS += -no-opengl -no-eglfs
 endif
@@ -125,6 +129,8 @@ define QT5BASE_CONFIGURE_CMDS
        $(call QT5BASE_CONFIG_SET,CROSS_COMPILE,$(TARGET_CROSS))
        $(call QT5BASE_CONFIG_SET,COMPILER_CFLAGS,$(TARGET_CFLAGS))
        $(call QT5BASE_CONFIG_SET,COMPILER_CXXFLAGS,$(TARGET_CXXFLAGS))
+       $(call QT5BASE_CONFIG_SET,EGLFS_PLATFORM_HOOKS_SOURCES, \
+               $(QT5BASE_EGLFS_PLATFORM_HOOKS_SOURCES))
        (cd $(@D); \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
                PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig" \