boot/syslinux: add an option to install a MBR blob
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 2 May 2014 17:10:36 +0000 (19:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 May 2014 20:00:00 +0000 (22:00 +0200)
This MBR blob will look for an active partition, and boot the bootcode
present in that partition. This can be used to boot an extlinux-prepared
partition.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Lundquist <lists@zelow.no>
Cc: Frank Hunleth <fhunleth@troodon-software.com>
Tested-by: Frank Hunleth <fhunleth@troodon-software.com>
Tested-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/syslinux/Config.in
boot/syslinux/syslinux.mk

index 5f0fe978faa949c26afb4ffab55b8dd4d2ee9431..28c5329ca715603b9ee097939885d379d1b58495 100644 (file)
@@ -30,6 +30,14 @@ config BR2_TARGET_SYSLINUX_PXELINUX
          Install the legacy-BIOS 'pxelinux' image, to boot off
          the network using PXE.
 
+config BR2_TARGET_SYSLINUX_MBR
+       bool "mbr"
+       select BR2_TARGET_SYSLINUX_LEGACY_BIOS
+       help
+         Install the legacy-BIOS 'mbr' image, to boot off a
+         local MBR-partition (e.g. prepared with 'extlinux'
+         or 'syslinux').
+
 config BR2_TARGET_SYSLINUX_EFI
        bool "efi"
        select BR2_PACKAGE_GNU_EFI
index 95ece52d3be650bdac60d88f803ec2472f327cc1..5432d0ac36c215fdf03640283a82e36b94aaaa22 100644 (file)
@@ -60,6 +60,7 @@ endef
 
 SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_ISOLINUX) += bios/core/isolinux.bin
 SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_PXELINUX) += bios/core/pxelinux.bin
+SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_MBR) += bios/mbr/mbr.bin
 SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_EFI) += $(SYSLINUX_EFI_BITS)/efi/syslinux.efi
 
 define SYSLINUX_INSTALL_IMAGES_CMDS