sg3_utils: bump to version 1.37
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 29 Jan 2014 13:11:40 +0000 (10:11 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 29 Jan 2014 20:40:28 +0000 (21:40 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sg3_utils/sg3_utils.mk

index 8bb79b5744de4baba8ac32536d601e1284088cd3..be86bd77c943295345d5fdca33177e372e0c50cf 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-SG3_UTILS_VERSION = 1.34
+SG3_UTILS_VERSION = 1.37
 SG3_UTILS_SOURCE = sg3_utils-$(SG3_UTILS_VERSION).tar.xz
-SG3_UTILS_SITE    = http://sg.danny.cz/sg/p/
+SG3_UTILS_SITE  = http://sg.danny.cz/sg/p/
 SG3_UTILS_LICENSE = BSD-3c
 # utils progs are GPLv2+ licenced
 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),y)
@@ -20,7 +20,8 @@ SG3_UTILS_INSTALL_STAGING = YES
 ifeq ($(BR2_PACKAGE_SG3_UTILS_PROGS),)
 define SG3_UTILS_REMOVE_PROGS
        for prog in \
-               dd decode_sense emc_trespass format get_config \
+               compare_and_write copy_results dd decode_sense \
+               emc_trespass format get_config \
                get_lba_status ident inq logs luns map26 \
                map sgm_dd modes opcodes sgp_dd persist prevent \
                raw rbuf rdac read readcap read_block_limits \
@@ -29,10 +30,18 @@ define SG3_UTILS_REMOVE_PROGS
                sat_identify sat_phy_event sat_set_features scan \
                senddiag ses start stpg sync test_rwbuf turs \
                unmap verify vpd write_buffer write_long \
-               write_same wr_mode ; do \
+               write_same wr_mode xcopy; do \
                $(RM) $(TARGET_DIR)/usr/bin/sg_$${prog} ; \
        done
-       $(RM) $(TARGET_DIR)/usr/bin/sginfo
+       for prog in \
+               logging_level mandat readcap ready satl start stop \
+               temperature; do \
+               $(RM) $(TARGET_DIR)/usr/bin/scsi_$${prog} ; \
+       done
+       for prog in \
+               sginfo sgm_dd sgp_dd; do \
+               $(RM) $(TARGET_DIR)/usr/bin/$${prog}; \
+       done
 endef
 
 SG3_UTILS_POST_INSTALL_TARGET_HOOKS += SG3_UTILS_REMOVE_PROGS