qt5serialport: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:32:05 +0000 (08:32 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:15 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `serialport' from the staging directory
to the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5serialport/qt5serialport.mk

index 1cddaf857eec27ef722c20fd2a88da6363ef7505..2b0953586b0bac96e8f501bedb992a0de7d68907 100644 (file)
@@ -32,9 +32,20 @@ define QT5SERIALPORT_INSTALL_STAGING_CMDS
 endef
 
 ifeq ($(BR2_STATIC_LIBS),)
-define QT5SERIALPORT_INSTALL_TARGET_CMDS
+define QT5SERIALPORT_INSTALL_TARGET_LIBS
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5SerialPort.so.* $(TARGET_DIR)/usr/lib
 endef
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5SERIALPORT_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/serialport $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
+define QT5SERIALPORT_INSTALL_TARGET_CMDS
+       $(QT5SERIALPORT_INSTALL_TARGET_LIBS)
+       $(QT5SERIALPORT_INSTALL_TARGET_EXAMPLES)
+endef
+
 $(eval $(generic-package))