sed: fix compilation with external toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2009 19:42:48 +0000 (21:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2009 19:45:04 +0000 (21:45 +0200)
Since CC is already passed in TARGET_CONFIGURE_OPTS at ./configure
time, there's no point in overriding it with a wrong value at
compilation time. This breaks external toolchain builds since
CC=$(TARGET_CC) is wrong because it excludes the mandatory --sysroot
option.

Fixes bug #525

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
CHANGES
package/sed/sed.mk

diff --git a/CHANGES b/CHANGES
index 0c1f667b1790f91981da5a6851193a2e6cbbce34..36b9b45ea7bde08eaaf5398e8e1a8ba568ec3fe9 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -77,6 +77,7 @@
        #497: OpenSSL RSA key generation hangs on x86_64
        #509: Bump sqlite package to 3.6.16
        #523: pciutils broken with external toolchain
+       #525: sed broken with external toolchain
        #533: Update gamin to 0.1.10 to fix compilation
 
 2009.05, Released June 1st, 2009:
index 9caefed4930955f42567e79fc373b1664f8ccb53..07f4b32c624180184427da6febc178ae9f639abf 100644 (file)
@@ -135,7 +135,7 @@ $(SED_DIR2)/.configured: $(SED_DIR2)/.unpacked
        touch $@
 
 $(SED_DIR2)/$(SED_BINARY): $(SED_DIR2)/.configured
-       $(MAKE) CC=$(TARGET_CC) -C $(SED_DIR2)
+       $(MAKE) -C $(SED_DIR2)
 
 # This stuff is needed to work around GNU make deficiencies
 sed-target_binary: $(SED_DIR2)/$(SED_BINARY)