package/c-icap: add optional support for openldap
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 May 2017 21:41:18 +0000 (23:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 May 2017 13:39:03 +0000 (15:39 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 17f3459abae6c6dd52393aa2eb84530bf59f6514..2d8b30920bba646585f9ed701a55947ca17d0f0f 100644 (file)
@@ -13,7 +13,6 @@ C_ICAP_INSTALL_STAGING = YES
 C_ICAP_CONFIG_SCRIPTS = c-icap-config c-icap-libicapapi-config
 C_ICAP_CONF_OPTS = \
        --with-process-mutexes=posix \
-       --without-ldap \
        --without-perl \
        --enable-large-files \
        --enable-ipv6
@@ -42,6 +41,13 @@ else
 C_ICAP_CONF_OPTS += --without-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_OPENLDAP),y)
+C_ICAP_CONF_OPTS += --with-ldap
+C_ICAP_DEPENDENCIES += openldap
+else
+C_ICAP_CONF_OPTS += --without-ldap
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 C_ICAP_CONF_OPTS += --with-zlib
 C_ICAP_DEPENDENCIES += zlib