knock: new package
authorMichael Rommel <rommel@layer-7.net>
Sun, 8 Sep 2013 15:22:58 +0000 (17:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 12 Sep 2013 08:45:14 +0000 (10:45 +0200)
A port knocking implementation with daemon and user application.

[Peter: drop trailing newline in Config.in]
Signed-off-by: Michael Rommel <rommel@layer-7.net>
Acked-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/knock/Config.in [new file with mode: 0644]
package/knock/knock.mk [new file with mode: 0644]

index 2351839c9872dea9ce579f49b1886c73de46a690..02e5afceba4566b940e81032b082a1e5c75b4370 100644 (file)
@@ -789,6 +789,7 @@ source "package/ipset/Config.in"
 source "package/iptables/Config.in"
 source "package/iw/Config.in"
 source "package/kismet/Config.in"
+source "package/knock/Config.in"
 source "package/lighttpd/Config.in"
 source "package/linknx/Config.in"
 source "package/links/Config.in"
diff --git a/package/knock/Config.in b/package/knock/Config.in
new file mode 100644 (file)
index 0000000..a50860b
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_KNOCK
+       bool "knock"
+       select BR2_PACKAGE_LIBPCAP
+       help
+         A port knocking implementation.
+         Provides a daemon and a user application. Port knocking can be
+         used to run an arbitrary application, once the daemon detects
+         a predefined sequence of incoming TCP/UDP packets on a network
+         interface. This can be used, e.g. to open up ports in a
+         firewall.
+
+         http://www.zeroflux.org/projects/knock
diff --git a/package/knock/knock.mk b/package/knock/knock.mk
new file mode 100644 (file)
index 0000000..8469b4f
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# knock
+#
+################################################################################
+
+KNOCK_VERSION = 7666f2e86e
+KNOCK_SITE = https://github.com/jvinet/knock/tarball/master
+KNOCK_LICENSE = GPLv2+
+KNOCK_LICENSE_FILES = COPYING
+KNOCK_AUTORECONF = YES
+KNOCK_DEPENDENCIES = libpcap
+
+$(eval $(autotools-package))