mplayer: use BR2_ARM_CPU_ARM* options
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:26:55 +0000 (22:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 22:29:26 +0000 (23:29 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mplayer/Config.in
package/mplayer/mplayer.mk

index 978eefe9bb48c3775937baa20ae082b46eb2a6ff..4cfa0bb14adafb5d3bbdfceae0e275c82e5121a4 100644 (file)
@@ -4,8 +4,7 @@ config BR2_PACKAGE_MPLAYER
        depends on !(BR2_bfin || BR2_sh2a || BR2_sh4a || BR2_sh4aeb \
                || BR2_microblaze || BR2_aarch64 || BR2_nios2)
        # Broken support for <ARMv5
-       depends on !(BR2_arm920t || BR2_arm920t || BR2_arm922t || BR2_fa526 \
-               || BR2_strongarm)
+       depends on !BR2_ARM_CPU_ARMV4
        depends on BR2_LARGEFILE
        help
          MPlayer is a movie player which runs on many systems and supports
index 0c216d799c7674cf729fae787aa0fef605bc59ad..ee023b4ca39d0d7d2f15dd1430b2544a665c801f 100644 (file)
@@ -105,11 +105,11 @@ MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBX11),xlib_libX11)
 MPLAYER_DEPENDENCIES += $(if $(BR2_PACKAGE_XLIB_LIBXV),xlib_libXv)
 
 # ARM optimizations
-ifeq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),armv5te)
+ifeq ($(BR2_ARM_CPU_ARMV5),y)
 MPLAYER_CONF_OPTS += --enable-armv5te
 endif
 
-ifeq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),armv6j)
+ifeq ($(BR2_ARM_CPU_ARMV6),y)
 MPLAYER_CONF_OPTS += --enable-armv6
 endif