ifplugd: remove spurious newline escape
authorBaruch Siach <baruch@tkos.co.il>
Tue, 2 Dec 2014 06:58:49 +0000 (08:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Dec 2014 08:39:14 +0000 (09:39 +0100)
Commit 5ad5d55924bcc (ifplugd: install configuration files unconditionally)
removed the conditional configuration file install, but left an redundant
newline escape, causing the following error:

package/ifplugd/ifplugd.mk:23: *** missing 'endef', unterminated 'define'.  Stop.

Fix this.

Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ifplugd/ifplugd.mk

index 03ed8cdf33a2c1604ee0e7b422ee22856ceb18fb..6b6141e7b8b3f27b0734cf85602dcdc6e28a1f88 100644 (file)
@@ -24,7 +24,7 @@ define IFPLUGD_INSTALL_FIXUP
        $(INSTALL) -D -m 0644 $(@D)/conf/ifplugd.conf $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
        $(SED) 's^\(ARGS=.*\)w^\1^' $(TARGET_DIR)/etc/ifplugd/ifplugd.conf; \
        $(INSTALL) -D -m 0755 $(@D)/conf/ifplugd.action \
-               $(TARGET_DIR)/etc/ifplugd/ifplugd.action ; \
+               $(TARGET_DIR)/etc/ifplugd/ifplugd.action
 endef
 
 IFPLUGD_POST_INSTALL_TARGET_HOOKS += IFPLUGD_INSTALL_FIXUP