package/freescale-imx/imx-gpu-viv: remove fb headers fixup
authorGary Bisson <gary.bisson@boundarydevices.com>
Tue, 27 Oct 2020 17:12:45 +0000 (18:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 29 Oct 2020 22:34:06 +0000 (23:34 +0100)
As it doesn't seem to be needed any longer. Also it was agreed to fix
packages not using pkgconfig properly instead of doing this sed.

Tested on i.MX6 platform with Qt5, no more issues.

Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/imx-gpu-viv/imx-gpu-viv.mk

index b6b070e4f6b5e0df59838b6b00bb66cec7741214..fca8a4d4473209599e88d36e30eabd7488f3afa0 100644 (file)
@@ -58,15 +58,6 @@ define IMX_GPU_VIV_BUILD_CMDS
        ln -sf libVDK-$(IMX_GPU_VIV_LIB_TARGET).so $(@D)/gpu-core/usr/lib/libVDK.so
 endef
 
-ifeq ($(IMX_GPU_VIV_LIB_TARGET),fb)
-define IMX_GPU_VIV_FIXUP_FB_HEADERS
-       $(SED) '39i\
-               #if !defined(EGL_API_X11) && !defined(EGL_API_DFB) && !defined(EGL_API_FB) \n\
-               #define EGL_API_FB \n\
-               #endif' $(STAGING_DIR)/usr/include/EGL/eglplatform.h
-endef
-endif
-
 ifeq ($(IMX_GPU_VIV_LIB_TARGET),fb)
 define IMX_GPU_VIV_FIXUP_PKGCONFIG
        ln -sf egl_linuxfb.pc $(@D)/gpu-core/usr/lib/pkgconfig/egl.pc
@@ -89,7 +80,6 @@ endif
 
 define IMX_GPU_VIV_INSTALL_STAGING_CMDS
        cp -r $(@D)/gpu-core/usr/* $(STAGING_DIR)/usr
-       $(IMX_GPU_VIV_FIXUP_FB_HEADERS)
        $(IMX_GPU_VIV_FIXUP_PKGCONFIG)
        for lib in egl gbm glesv1_cm glesv2 vg; do \
                $(INSTALL) -m 0644 -D \