package/linux-tools: add gpio
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 4 Oct 2016 16:01:14 +0000 (18:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Oct 2016 20:56:10 +0000 (22:56 +0200)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-tools/Config.in
package/linux-tools/linux-tool-gpio.mk [new file with mode: 0644]

index 61c196f912a334d8c9c0023294870b005f5a5137..bd07509f0f7c68d77339fba3e17867f3225b38bc 100644 (file)
@@ -20,6 +20,18 @@ comment "cpupower needs a toolchain w/ wchar"
        depends on !BR2_bfin
        depends on !BR2_USE_WCHAR && BR2_NEEDS_GETTEXT
 
+config BR2_PACKAGE_LINUX_TOOLS_GPIO
+       bool "gpio"
+       select BR2_PACKAGE_LINUX_TOOLS
+       help
+         gpio is a collection of tools to get information about,
+         control and monitor gpios present on system.
+
+         These tools use new gpio ABI which will deprecate sysfs gpio
+         interface in the future.
+
+         These tools are available only from kernel version 4.8.
+
 config BR2_PACKAGE_LINUX_TOOLS_PERF
        bool "perf"
        select BR2_PACKAGE_LINUX_TOOLS
diff --git a/package/linux-tools/linux-tool-gpio.mk b/package/linux-tools/linux-tool-gpio.mk
new file mode 100644 (file)
index 0000000..ba75ab4
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# gpio
+#
+################################################################################
+
+LINUX_TOOLS += gpio
+
+GPIO_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
+
+define GPIO_BUILD_CMDS
+       $(Q)if ! grep install $(LINUX_DIR)/tools/gpio/Makefile >/dev/null 2>&1 ; then \
+               echo "Your kernel version is too old and does not have the gpio tools." ; \
+               echo "At least kernel 4.8 must be used." ; \
+               exit 1 ; \
+       fi
+
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
+               $(GPIO_MAKE_OPTS) \
+               gpio
+endef
+
+define GPIO_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools \
+               $(GPIO_MAKE_OPTS) \
+               DESTDIR=$(TARGET_DIR) \
+               gpio_install
+endef