package/perl-net-dns: New package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Apr 2015 10:16:59 +0000 (12:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 11:43:44 +0000 (13:43 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-net-dns/Config.in [new file with mode: 0644]
package/perl-net-dns/perl-net-dns.hash [new file with mode: 0644]
package/perl-net-dns/perl-net-dns.mk [new file with mode: 0644]

index 1f9c9085bc97936763657009bda37c290174142c..a6d5dcff93a6e15dc6f17be5ccc6fa420419ab6e 100644 (file)
@@ -513,6 +513,7 @@ menu "Perl libraries/modules"
        source "package/perl-io-socket-ssl/Config.in"
        source "package/perl-json-tiny/Config.in"
        source "package/perl-mojolicious/Config.in"
+       source "package/perl-net-dns/Config.in"
        source "package/perl-net-ssleay/Config.in"
        source "package/perl-netaddr-ip/Config.in"
        source "package/perl-path-tiny/Config.in"
diff --git a/package/perl-net-dns/Config.in b/package/perl-net-dns/Config.in
new file mode 100644 (file)
index 0000000..52fb4d8
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PERL_NET_DNS
+       bool "perl-net-dns"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PERL_DIGEST_HMAC
+       help
+         Net::DNS is a DNS resolver implemented in Perl.
+
+         http://www.net-dns.org
+
+comment "perl-net-dns needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-net-dns/perl-net-dns.hash b/package/perl-net-dns/perl-net-dns.hash
new file mode 100644 (file)
index 0000000..01d2772
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    f1d48107ff6b366479ad035783486d7a Net-DNS-0.83.tar.gz
+sha256 8e1108d1801b9695909859323e1ed2f7ffb3b03dd3d2028a19fb79fc1a1d7c39 Net-DNS-0.83.tar.gz
diff --git a/package/perl-net-dns/perl-net-dns.mk b/package/perl-net-dns/perl-net-dns.mk
new file mode 100644 (file)
index 0000000..75c0a1b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-net-dns
+#
+################################################################################
+
+PERL_NET_DNS_VERSION = 0.83
+PERL_NET_DNS_SOURCE = Net-DNS-$(PERL_NET_DNS_VERSION).tar.gz
+PERL_NET_DNS_SITE = $(BR2_CPAN_MIRROR)/authors/id/N/NL/NLNETLABS
+PERL_NET_DNS_DEPENDENCIES = perl perl-digest-hmac
+PERL_NET_DNS_LICENSE = Artistic or GPLv1+
+PERL_NET_DNS_LICENSE_FILES = README
+
+$(eval $(perl-package))