external-toolchain: only copy existing directories of the sysroot
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 Jul 2010 16:58:56 +0000 (18:58 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Jul 2010 05:56:26 +0000 (07:56 +0200)
Instead of copying all directories in "etc lib sbin usr", check that
each of them exists before doing the copy. This is only to avoid an
harmless error message.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/external-toolchain/ext-tool.mk

index b1eee23039057e96291f7768ecc8f34f4de39722..9c1ec8f287684e9c066149d369d1426fd25c9999 100644 (file)
@@ -120,7 +120,9 @@ copy_toolchain_sysroot = \
        ARCH_SYSROOT_DIR="$(strip $2)"; \
        ARCH_SUBDIR="$(strip $3)"; \
        for i in etc lib sbin usr ; do \
-               cp -a $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
+               if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
+                       cp -a $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
+               fi ; \
        done ; \
        if [ `readlink -f $${SYSROOT_DIR}` != `readlink -f $${ARCH_SYSROOT_DIR}` ] ; then \
                if [ ! -d $${ARCH_SYSROOT_DIR}/usr/include ] ; then \