post-image: show each script filename before execution
authorLuca Ceresoli <luca@lucaceresoli.net>
Mon, 8 Apr 2013 06:50:15 +0000 (06:50 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 24 Apr 2013 20:13:44 +0000 (22:13 +0200)
This also simplifies code by removing the ifneq/endif clauses.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index e825bcdfaa0aef092e368d1a57a5e61cb9853f6c..840aa1fe9fb359fd8c8a84b0840b791537a5f5fc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -555,11 +555,9 @@ target-generatelocales: host-localedef
 endif
 
 target-post-image:
-ifneq ($(BR2_ROOTFS_POST_IMAGE_SCRIPT),"")
-       @$(call MESSAGE,"Executing post-image script\(s\)")
        @$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_IMAGE_SCRIPT)), \
+               $(call MESSAGE,"Executing post-image script $(s)"); \
                $(s) $(BINARIES_DIR)$(sep))
-endif
 
 toolchain-eclipse-register:
        ./support/scripts/eclipse-register-toolchain `readlink -f $(O)` $(notdir $(TARGET_CROSS)) $(BR2_ARCH)