kismet: bump to version 2013-03-R1b
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 11 Apr 2013 23:49:41 +0000 (23:49 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 12 Apr 2013 09:56:04 +0000 (11:56 +0200)
Fixes issues in the configure script.
Also make libnl a mandatory dependency to fix:
http://autobuild.buildroot.net/results/c8bf63f4ee013bd3467934c87c61478a1f95e3eb/
Kismet isn't too useful without it anyway.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/kismet/Config.in
package/kismet/kismet.mk

index 695466542140293292b35f4e5c5c56ed4ae2b07b..8de29beea4ce3d858c85edc3cba14197cc2c29d8 100644 (file)
@@ -1,12 +1,14 @@
-comment "Kismet requires a toolchain with C++ support enabled"
-       depends on !BR2_INSTALL_LIBSTDCPP
+comment "Kismet requires a toolchain with thread and C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
 
 config BR2_PACKAGE_KISMET
        bool "kismet"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
        select BR2_PACKAGE_NCURSES
        select BR2_PACKAGE_NCURSES_TARGET_PANEL
        select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_LIBNL
        help
          Kismet - 802.11 layer2 wireless network detector, sniffer,
          and intrusion detection system.
index 5abc92c1447bd317b1c939b4d6a8f5fad098dcd8..1fb3f5a29e66e0a6039879fd459ebe6cc625dff5 100644 (file)
@@ -4,16 +4,13 @@
 #
 #############################################################
 
-KISMET_VERSION = 2013-03-R1a
+KISMET_VERSION = 2013-03-R1b
 KISMET_SITE = http://www.kismetwireless.net/code
-KISMET_DEPENDENCIES = host-pkgconf libpcap ncurses
+KISMET_DEPENDENCIES = host-pkgconf libpcap ncurses libnl
+KISMET_CONF_OPT += --with-netlink-version=3
 KISMET_LICENSE = GPLv2+
 KISMET_LICENSE_FILES = debian/copyright
 
-ifeq ($(BR2_PACKAGE_LIBNL),y)
-       KISMET_DEPENDENCIES += libnl
-       KISMET_CONF_OPT += --with-netlink-version=3
-endif
 ifeq ($(BR2_PACKAGE_PCRE),y)
        KISMET_DEPENDENCIES += pcre
 endif