u-boot: add a few comments
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 31 May 2010 17:34:27 +0000 (19:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jun 2010 11:23:48 +0000 (13:23 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/u-boot/u-boot.mk

index 220eeb2b65663e35d7dd9695c6d75ee587be9351..90a45b87f9a181162da1f8f6633632c308ded94e 100644 (file)
@@ -108,6 +108,7 @@ endif
 endif # BR2_TARGET_UBOOT_NETWORK
        touch $@
 
+# Build U-Boot itself
 $(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
        $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -116,6 +117,7 @@ $(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
                $(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) \
                 -C $(U_BOOT_DIR)
 
+# Copy the result to the images/ directory
 $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
        rm -f $(BINARIES_DIR)/$(U_BOOT_BIN)
        cp -dpf $(U_BOOT_DIR)/$(U_BOOT_BIN) $(BINARIES_DIR)/
@@ -129,6 +131,7 @@ $(MKIMAGE): $(U_BOOT_DIR)/.patched
        $(MAKE) -C $(U_BOOT_DIR) tools
        cp -dpf $(U_BOOT_DIR)/tools/mkimage $(@D)
 
+# Build manually mkimage for the target
 $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
        mkdir -p $(@D)
        $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(U_BOOT_DIR)/tools \
@@ -142,6 +145,7 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
 
        $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
 
+# Build manually fw_printenv for the target
 $(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/.configured
        mkdir -p $(@D)
        $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \