msmtp: enable msmtpd if MMU is available
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Nov 2018 11:58:41 +0000 (12:58 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 18 Nov 2018 21:00:00 +0000 (22:00 +0100)
msmtpd uses fork so enable it if MMU is available

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/msmtp/msmtp.mk

index 23705916144af8daba47f619f448c9b592e193ff..a495072abff9017a4e160538b6b8762c6ca74db1 100644 (file)
@@ -8,10 +8,17 @@ MSMTP_VERSION = 1.8.0
 MSMTP_SITE = https://marlam.de/msmtp/releases
 MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
 MSMTP_DEPENDENCIES = host-pkgconf
-MSMTP_CONF_OPTS = --disable-gai-idn --without-msmtpd
+MSMTP_CONF_OPTS = --disable-gai-idn
 MSMTP_LICENSE = GPL-3.0+
 MSMTP_LICENSE_FILES = COPYING
 
+# msmtpd needs fork
+ifeq ($(BR2_USE_MMU),y)
+MSMTP_CONF_OPTS += --with-msmtpd
+else
+MSMTP_CONF_OPTS += --without-msmtpd
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGSASL),y)
 MSMTP_CONF_OPTS += --with-libgsasl
 MSMTP_DEPENDENCIES += libgsasl